Unbreak on CURRENT
This commit is contained in:
parent
9a44066fbb
commit
fe8762f0a6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=147407
4 changed files with 22 additions and 8 deletions
|
@ -38,10 +38,6 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700000
|
||||
BROKEN= "Does not compile on FreeBSD >= 7.0"
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${CP} ${LTMAIN} ${WRKSRC}/autoconf
|
||||
|
||||
|
|
11
devel/commoncpp/files/patch-src_mutex.cpp
Normal file
11
devel/commoncpp/files/patch-src_mutex.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/mutex.cpp.orig Sat Nov 5 19:54:24 2005
|
||||
+++ src/mutex.cpp Sat Nov 5 19:59:01 2005
|
||||
@@ -48,6 +48,8 @@
|
||||
using namespace __gnu_cxx;
|
||||
#endif
|
||||
|
||||
+using namespace std;
|
||||
+
|
||||
#ifdef CCXX_NAMESPACES
|
||||
namespace ost {
|
||||
#endif
|
|
@ -43,10 +43,6 @@ PLIST_SUB+= MMAN_CACHE=${MMAN_CACHE}
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700000
|
||||
BROKEN= "Does not compile on FreeBSD >= 7.0"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|/usr/bin/mman|${PREFIX}/bin/mman|g ; \
|
||||
|
|
11
www/middleman/files/patch-include-types.h
Normal file
11
www/middleman/files/patch-include-types.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- include/types.h.orig Sat Nov 5 19:51:41 2005
|
||||
+++ include/types.h Sat Nov 5 19:51:54 2005
|
||||
@@ -1,6 +1,8 @@
|
||||
#ifndef TYPES_H
|
||||
#define TYPES_H
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
struct unlink_list {
|
||||
struct unlink_list *next;
|
||||
char *path;
|
Loading…
Reference in a new issue