- Update to upstream version 1.2.2

- Add non-default OPTION PDF
- Disable LILYPOND OPTION for now due to conflicting dependencies
- Retire pkg-plist in favor of PLIST_*

PR:		199208
Submitted by:	tkato432@yahoo.com
Reviewed by:	riggs
This commit is contained in:
Thomas Zander 2015-05-03 20:02:29 +00:00
parent 66612130bb
commit fea7b304fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=385343
7 changed files with 67 additions and 2623 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= denemo
PORTVERSION= 1.1.8
PORTREVISION= 4
PORTVERSION= 1.2.2
CATEGORIES= audio
MASTER_SITES= GNU
@ -15,11 +14,11 @@ LICENSE= GPLv3
LIB_DEPENDS= libaubio.so:${PORTSDIR}/audio/aubio \
libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
libjack.so:${PORTSDIR}/audio/jack \
libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
libsmf.so:${PORTSDIR}/audio/libsmf \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
librubberband.so:${PORTSDIR}/audio/rubberband \
libguile.so:${PORTSDIR}/lang/guile \
libguile-2.0.so:${PORTSDIR}/lang/guile2 \
libfftw3.so:${PORTSDIR}/math/fftw3
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
@ -27,38 +26,75 @@ USES= bison gettext gmake pkgconfig
USE_GNOME= librsvg2 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-jack \
--disable-evince \
--disable-alsa \
--disable-portmidi \
--sysconfdir=${PREFIX}/etc
--disable-gtk-doc \
--disable-gtk-doc-html \
--disable-gtk-doc-pdf
CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 \
-I${LOCALBASE}/include
LDFLAGS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so \
-L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS EXAMPLES GTK3 LILYPOND
PORTDOCS= *
PORTEXAMPLES= *
PORTDATA= *
PLIST_FILES= bin/cairo_svg2path \
bin/denemo \
bin/denemo_file_update \
bin/generate_source \
share/appdata/denemo.appdata.xml \
share/applications/denemo.desktop \
share/fonts/truetype/denemo/Denemo.ttf \
share/fonts/truetype/denemo/emmentaler.ttf \
share/fonts/truetype/denemo/feta.ttf \
share/pixmaps/denemo.png
.for i in cs de en_GB es fr it ja pl sv
PLIST_FILES+= share/locale/${i}/LC_MESSAGES/denemo.mo
.endfor
OPTIONS_DEFINE= DOCS EXAMPLES LILYPOND PDF
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
OPTIONS_DEFAULT= GTK3
GTK2_USE= gnome=gtk20,gtksourceview2
GTK2_CONFIGURE_ON= --enable-gtk2
GTK3_USE= gnome=gtk30,gtksourceview3
LILYPOND_DESC= Install LilyPond (Printing)
LILYPOND_RUN_DEPENDS= lilypond:${PORTSDIR}/print/lilypond
PDF_CONFIGURE_OFF= --disable-evince
TOOLKIT_DESC= GTK+ toolkit
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK3}
USE_GNOME+= gtk30 gtksourceview3
.else
USE_GNOME+= gtk20 gtksourceview2
CONFIGURE_ARGS+=--enable-gtk2
.if ${PORT_OPTIONS:MLILYPOND}
BROKEN= Depends transitively on conflicting versions of guile
.endif
.if ${PORT_OPTIONS:MGTK3} && ${PORT_OPTIONS:MPDF}
LIB_DEPENDS+= libevview3.so:${PORTSDIR}/graphics/evince
.endif
.if ${PORT_OPTIONS:MGTK2} && ${PORT_OPTIONS:MPDF}
LIB_DEPENDS+= libatrilview.so:${PORTSDIR}/graphics/atril
.endif
post-patch:
@${REINPLACE_CMD} -e \
'/^CFLAGS=/s|_LIBS|_CFLAGS| ; \
s|-lpthread|-pthread|' ${WRKSRC}/configure
's|-lpthread|-pthread| ; \
/^CFLAGS=/s|_LIBS|_CFLAGS| ; \
s|evince-view-2.32 >= 2.|atril-view-1.5.|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/ docs /d ; \
/) install-data-hook/s|^|#|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|"firefox"|"xdg-open"|' ${WRKSRC}/src/core/prefops.c
.if ${PORT_OPTIONS:MGTK2} && ${PORT_OPTIONS:MPDF}
@${FIND} ${WRKSRC}/src -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
'/^#include/s|evince|atril|'
.endif
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}

View file

@ -1,2 +1,2 @@
SHA256 (denemo-1.1.8.tar.gz) = 0290f6f3c70bf85dfff5de48ba040bfe268d88136d3908ffa3be70206483c08c
SIZE (denemo-1.1.8.tar.gz) = 14035344
SHA256 (denemo-1.2.2.tar.gz) = 9831da7e713fe0ad97bb9c358f18b36d83a1ef91cd15edf363d0b3f07df1dfee
SIZE (denemo-1.2.2.tar.gz) = 14240017

View file

@ -1,4 +1,4 @@
--- src/audio/dummybackend.c.orig
--- src/audio/dummybackend.c.orig 2015-02-09 02:55:09 UTC
+++ src/audio/dummybackend.c
@@ -21,9 +21,11 @@
static int const PLAYBACK_INTERVAL = 100000;
@ -12,7 +12,7 @@
static gboolean dummy_audio = FALSE;
static gboolean dummy_midi = FALSE;
@@ -31,6 +33,7 @@
@@ -31,6 +33,7 @@ static gboolean dummy_midi = FALSE;
static double playback_start_time;
@ -20,7 +20,7 @@
static gpointer
process_thread_func (gpointer data)
{
@@ -118,6 +121,7 @@
@@ -117,6 +120,7 @@ stop_process_thread ()
process_thread = NULL;
}
}
@ -28,7 +28,7 @@
static int
@@ -125,7 +129,9 @@
@@ -124,7 +128,9 @@ dummy_audio_initialize (DenemoPrefs * co
{
g_message ("Initializing dummy audio backend");
@ -38,7 +38,7 @@
g_atomic_int_set (&dummy_audio, TRUE);
@@ -137,7 +143,9 @@
@@ -136,7 +142,9 @@ dummy_midi_initialize (DenemoPrefs * con
{
g_message ("Initializing dummy MIDI backend");
@ -48,7 +48,7 @@
g_atomic_int_set (&dummy_midi, TRUE);
@@ -152,7 +160,9 @@
@@ -151,7 +159,9 @@ dummy_audio_destroy ()
g_atomic_int_set (&dummy_audio, FALSE);
@ -58,7 +58,7 @@
return 0;
}
@@ -164,7 +174,9 @@
@@ -163,7 +173,9 @@ dummy_midi_destroy ()
g_atomic_int_set (&dummy_midi, FALSE);

View file

@ -1,6 +1,6 @@
--- src/export/file.c.orig
--- src/export/file.c.orig 2015-02-09 02:55:09 UTC
+++ src/export/file.c
@@ -595,7 +595,7 @@
@@ -615,7 +615,7 @@ template_open (DenemoProject * gui, Temp
{
if (system_example_path == NULL)
{

View file

@ -1,6 +1,6 @@
--- src/ui/help.c.orig
--- src/ui/help.c.orig 2015-02-09 02:55:09 UTC
+++ src/ui/help.c
@@ -57,7 +57,7 @@
@@ -57,7 +57,7 @@ browse_manual (GtkAction * action, Denem
GError *error = NULL;
/* get the uri to the manual */

View file

@ -1,13 +1,13 @@
--- src/ui/mousing.c.orig
--- src/ui/mousing.c.orig 2015-02-09 02:55:09 UTC
+++ src/ui/mousing.c
@@ -215,7 +215,11 @@
@@ -219,7 +219,11 @@ get_placement_from_coordinates (struct p
pi->nextmeasure = ((si->system_height > 0.5 || x_to_explain > GPOINTER_TO_INT (mwidthiterator->data)) && pi->measure_number >= rightmeasurenum);
pi->the_staff = g_list_nth (si->thescore, pi->staff_number - 1);
- pi->the_measure = nth_measure_node_in_staff (pi->the_staff, pi->measure_number - 1);
- pi->the_measure = staff_nth_measure_node (pi->the_staff, pi->measure_number - 1);
+ if (pi->the_staff != NULL)
+ pi->the_measure
+ = nth_measure_node_in_staff (pi->the_staff, pi->measure_number - 1);
+ = staff_nth_measure_node (pi->the_staff, pi->measure_number - 1);
+ else
+ pi->the_measure = NULL;
if (pi->the_measure != NULL)

File diff suppressed because it is too large Load diff