This is an implementation of the sets game.
WWW: http://www.linuxmotors.com/sets/ PR: ports/167237 Submitted by: nemysis@gmx.ch
This commit is contained in:
parent
a7f5b7b018
commit
fea924855d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296595
5 changed files with 56 additions and 0 deletions
|
@ -804,6 +804,7 @@
|
|||
SUBDIR += secretmaryochronicles
|
||||
SUBDIR += secretmaryochronicles-music
|
||||
SUBDIR += senken
|
||||
SUBDIR += sets
|
||||
SUBDIR += sex
|
||||
SUBDIR += sfbol
|
||||
SUBDIR += shaaft
|
||||
|
|
40
games/sets/Makefile
Normal file
40
games/sets/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
|||
# New Ports collection makefile for: sets
|
||||
# Date created: 2012-04-21
|
||||
# Whom: nemysis@gmx.ch
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sets
|
||||
PORTVERSION= 1.0.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.linuxmotors.com/sets/downloads/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= nemysis@gmx.ch
|
||||
COMMENT= This is an implementation of the sets game
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
USE_SDL= sdl image
|
||||
|
||||
PLIST_FILES= bin/sets
|
||||
|
||||
PORTDOCS= README
|
||||
|
||||
do-install:
|
||||
# Executable
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
|
||||
post-install:
|
||||
# Documentation
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
. for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
. endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
games/sets/distinfo
Normal file
2
games/sets/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (sets-1.0.0.tgz) = 2521ea6352a7925965051897e9c92293cccf72d27968eca142b79b88e6700aab
|
||||
SIZE (sets-1.0.0.tgz) = 10108
|
10
games/sets/files/patch-Makefile
Normal file
10
games/sets/files/patch-Makefile
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Makefile.orig 2008-07-30 17:51:49.000000000 +0200
|
||||
+++ Makefile 2012-04-21 14:25:52.000000000 +0200
|
||||
@@ -1,5 +1,5 @@
|
||||
-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
|
||||
-LDFLAGS = -lm $(shell sdl-config --libs)
|
||||
+CFLAGS = $(shell ${SDL_CONFIG} --cflags)
|
||||
+LDFLAGS = -lm $(shell ${SDL_CONFIG} --libs)
|
||||
|
||||
all: sets
|
||||
|
3
games/sets/pkg-descr
Normal file
3
games/sets/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
This is an implementation of the sets game.
|
||||
|
||||
WWW: http://www.linuxmotors.com/sets/
|
Loading…
Reference in a new issue