Remove gnomeprint support, which is deprecated in gnome for a while now.

This commit is contained in:
Baptiste Daroussin 2019-12-26 21:33:43 +00:00
parent 01ad926802
commit fecdb79e78
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=520955
2 changed files with 27 additions and 10 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= linuxcnc
PORTVERSION= 20170708
PORTREVISION= 16
PORTREVISION= 17
CATEGORIES= cad
PKGNAMESUFFIX= -devel
@ -45,7 +45,7 @@ MAKE_ENV= BUILD_VERBOSE=1
USES= autoreconf gettext gl gmake gnome ncurses pkgconfig python:2.7 \
readline shebangfix tk xorg
USE_GL= gl glu
USE_GNOME= cairo gdkpixbuf2 libgnomeprintui pygtksourceview
USE_GNOME= cairo gdkpixbuf2 pygtksourceview
USE_XORG= ice sm x11 xext xft xinerama xmu xrender xscrnsaver xt
USE_LDCONFIG= yes
USE_GITHUB= yes

View file

@ -1,6 +1,6 @@
--- src/configure.in.orig 2016-06-25 02:19:12 UTC
--- src/configure.in.orig 2019-12-26 21:08:10 UTC
+++ src/configure.in
@@ -665,7 +665,7 @@ else
@@ -711,7 +711,7 @@ else
esac
LINUXCNC_CONFIG_PATH="~/linuxcnc/configs:/usr/local/etc/linuxcnc/configs:"$(eval echo $EMC2_HELP_DIR)"/examples/sample-configs"
EMC2_NCFILES_DIR=${prefix}/share/linuxcnc/ncfiles
@ -9,7 +9,24 @@
EMC2_IMAGE_DIR=$(fe "$datadir")/linuxcnc
HALLIB_DIR=${prefix}/share/linuxcnc/hallib
fi
@@ -807,25 +807,25 @@ then
@@ -787,16 +787,6 @@ if test "$BUILD_GTK" = "yes"; then
AC_MSG_RESULT(yes - $GTK_VER)
GTK_CFLAGS=`pkg-config gtk+-2.0 --cflags`
GTK_LIBS=`pkg-config gtk+-2.0 --libs`
- AC_MSG_CHECKING(for libgnomeprintui-2.2)
- if pkg-config --exists libgnomeprintui-2.2; then
- AC_MSG_RESULT(yes)
- GTK_CFLAGS="$GTK_CFLAGS `pkg-config --cflags libgnomeprintui-2.2`"
- GTK_LIBS="$GTK_LIBS `pkg-config --libs libgnomeprintui-2.2`"
- HAVE_GNOMEPRINT=yes
- else
- AC_MSG_RESULT(no -- printing from classicladder will not be possible)
- HAVE_GNOMEPRINT=
- fi
else
AC_MSG_RESULT(no)
AC_MSG_ERROR([GTK2 missing. Install it or specify --disable-gtk to skip the parts of LinuxCNC that depend on GTK])
@@ -853,25 +843,25 @@ then
AC_MSG_ERROR([awk not found])
fi
@ -39,11 +56,11 @@
if test $PIDOF = "none"
then
AC_MSG_ERROR([pidof not found])
@@ -1180,7 +1180,6 @@ AC_MSG_RESULT($HAVE_OPTRESET)
@@ -1211,7 +1201,6 @@ extern int optreset;
[HAVE_OPTRESET=no])
AC_MSG_RESULT($HAVE_OPTRESET)
AC_SUBST([HAVE_OPTRESET])
-
LIBS_hold=$LIBS
LIBS=
AC_SEARCH_LIBS(dlopen, [c dl], [