- Fix CONFLICTS on wmii-devel

- Silence stripping
- Regenerate patches
This commit is contained in:
Dmitry Marakasov 2017-02-08 09:01:26 +00:00
parent 540c646200
commit fed876bce5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433637
4 changed files with 14 additions and 14 deletions

View file

@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libixp.so:devel/libixp
RUN_DEPENDS= dmenu:x11/dmenu
CONFLICTS= wmii-3.9*
CONFLICTS= wmii-devel-[0-9]*
USE_XORG= x11 xextproto xt xext
@ -51,7 +51,7 @@ post-patch: .SILENT
post-install:
.for f in wmii wmii9menu wmiir
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
.include <bsd.port.mk>

View file

@ -1,4 +1,4 @@
--- mk/common.mk.orig 2007-11-16 21:59:15 +0800
--- mk/common.mk.orig 2007-11-16 13:59:15 UTC
+++ mk/common.mk
@@ -4,9 +4,9 @@ install: all

View file

@ -1,4 +1,4 @@
--- mk/hdr.mk.orig 2007-11-16 21:59:15 +0800
--- mk/hdr.mk.orig 2007-11-16 13:59:15 UTC
+++ mk/hdr.mk
@@ -26,32 +26,32 @@ all:

View file

@ -1,6 +1,6 @@
--- cmd/wmii/Makefile.orig
--- cmd/wmii/Makefile.orig 2007-11-16 13:59:15 UTC
+++ cmd/wmii/Makefile
@@ -8,8 +8,16 @@
@@ -8,8 +8,16 @@ TARG = wmii
HFILES= dat.h fns.h x11.h
LIB = ${LIBIXP}
@ -19,7 +19,7 @@
OBJ = area \
bar \
client \
--- cmd/wmii/utf.c.orig
--- cmd/wmii/utf.c.orig 2007-11-16 13:59:15 UTC
+++ cmd/wmii/utf.c
@@ -1,12 +1,17 @@
/* Public Domain --Kris Maglione */
@ -39,7 +39,7 @@
static iconv_t cd;
char *buf, *pos;
size_t nbuf, bsize;
@@ -30,6 +35,7 @@
@@ -30,6 +35,7 @@ toutf8n(char *str, size_t nstr) {
break;
*pos = '\0';
return buf;
@ -47,9 +47,9 @@
}
char*
--- cmd/wmii/x11.c.orig
--- cmd/wmii/x11.c.orig 2007-11-16 13:59:15 UTC
+++ cmd/wmii/x11.c
@@ -18,6 +18,12 @@
@@ -18,6 +18,12 @@ static Map wmap, amap;
static MapEnt *wbucket[137];
static MapEnt *abucket[137];
@ -62,7 +62,7 @@
XRectangle
XRect(Rectangle r) {
XRectangle xr;
@@ -444,7 +450,7 @@
@@ -444,7 +450,7 @@ drawstring(Image *dst, Font *font,
setgccol(dst, col);
if(font->set)
@ -71,7 +71,7 @@
font->set, dst->gc,
x, y,
buf, len);
@@ -552,7 +558,7 @@
@@ -552,7 +558,7 @@ textwidth_l(Font *font, char *text, uint
XRectangle r;
if(font->set) {
@ -80,7 +80,7 @@
return r.width;
}
return XTextWidth(font->xfont, text, len);
@@ -638,7 +644,7 @@
@@ -638,7 +644,7 @@ gettextlistproperty(Window *w, char *nam
XGetTextProperty(display, w->w, &prop, xatom(name));
if(prop.nitems > 0) {
@ -89,7 +89,7 @@
*ret = list;
XFree(prop.value);
}
@@ -653,9 +659,10 @@
@@ -653,9 +659,10 @@ gettextproperty(Window *w, char *name) {
str = nil;
n = gettextlistproperty(w, name, &list);