- Update to 4.7d
- Unbreak - Remove files/patch-system.h - Use mkstemp() instead of mktemp() - Pass maintainership to submitter PR: 90102 Submitted by: Thomas Vogt <thomas@bsdunix.ch>
This commit is contained in:
parent
e7e8131be9
commit
ff07e4f2da
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=150665
3 changed files with 15 additions and 26 deletions
|
@ -7,21 +7,29 @@
|
|||
#
|
||||
|
||||
PORTNAME= cproto
|
||||
PORTVERSION= 4.7c
|
||||
PORTVERSION= 4.7d
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://invisible-island.net/cproto/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= thomas@bsdunix.ch
|
||||
COMMENT= Generate C function prototypes and convert function definitions
|
||||
|
||||
BROKEN= Size mismatch
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
MAN1= cproto.1
|
||||
PLIST_FILES= bin/cproto
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|\(define\ MAX_INC_DEPTH\) 15|\1 25|' \
|
||||
-e 's|\(define MAX_TEXT_SIZE\) 256|\1 4096|' \
|
||||
${WRKSRC}/system.h
|
||||
@${REINPLACE_CMD} -e 's|mktemp|mkstemp|' \
|
||||
${WRKSRC}/${PORTNAME}.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
MD5 (cproto-4_7c.tgz) = c7fb8586a4b402e830d1310f3aadef91
|
||||
SIZE (cproto-4_7c.tgz) = 118592
|
||||
MD5 (cproto-4_7d.tgz) = d8aa3698dcf762b9fee94c5b9f1c294d
|
||||
SHA256 (cproto-4_7d.tgz) = aa341ffd8792002747c2cd59b8392707a950ac90b10904e93d9e776a07d69c9a
|
||||
SIZE (cproto-4_7d.tgz) = 144430
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- system.h.orig Fri Jan 23 17:42:09 1998
|
||||
+++ system.h Sun Jul 23 12:04:25 2000
|
||||
@@ -122,15 +122,15 @@
|
||||
/* maximum include file nesting */
|
||||
#ifndef MAX_INC_DEPTH
|
||||
-#define MAX_INC_DEPTH 15
|
||||
+#define MAX_INC_DEPTH 25
|
||||
#endif
|
||||
|
||||
/* maximum number of include directories */
|
||||
#ifndef MAX_INC_DIR
|
||||
-#define MAX_INC_DIR 15
|
||||
+#define MAX_INC_DIR 50
|
||||
#endif
|
||||
|
||||
/* maximum text buffer size */
|
||||
#ifndef MAX_TEXT_SIZE
|
||||
-#define MAX_TEXT_SIZE 256
|
||||
+#define MAX_TEXT_SIZE 4096
|
||||
#endif
|
Loading…
Reference in a new issue