- Fix MASTER_SITES

- Avoid some compiler warnings
- Remove obsolete WWW: line
- Bump PORTREVISION

PR:		59129
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-11-10 19:31:11 +00:00
parent 1f1a5c0d10
commit ff283bd66d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93686
6 changed files with 72 additions and 6 deletions

View file

@ -7,17 +7,20 @@
PORTNAME= snowflake
PORTVERSION= 0.01a
PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.infomatch.com/~donaldj/
DISTNAME= ${PORTNAME}
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= A snowflake image generator
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
USE_X_PREFIX= yes
USE_GNOME= gtk12
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/snowflake ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/snowflake ${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (snowflake.tar.gz) = 285a1ad22b85f7f78364d4e51774992f
MD5 (snowflake_0.01a.orig.tar.gz) = 8712dd23b8d4c30fc3261c69ffbc40e7

View file

@ -0,0 +1,44 @@
--- sf.c.orig Mon Dec 21 08:18:55 1998
+++ sf.c Sat Nov 8 21:20:24 2003
@@ -47,6 +47,7 @@
struct option long_options[] =
{
+ { "version", 0, 0, c_VERSION },
{ "view-geometry", 1, 0, c_VIEW_GEOMETRY },
{ "control-geometry", 1, 0, c_CONTROL_GEOMETRY },
{ "minimize", 0, 0, c_MINIMIZE },
@@ -77,6 +78,8 @@
help_info_line help_info[] =
{
+ { "version", c_VERSION, " ",
+ "show program version" },
{ "view-geometry", c_VIEW_GEOMETRY, "+x+y",
"Control window placement" },
{ "control-geometry", c_CONTROL_GEOMETRY, "+x+y",
@@ -134,7 +137,7 @@
/* ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ */
-void main( int argc,char* argv[] )
+int main( int argc,char* argv[] )
{
int i;
char* shop;
@@ -175,7 +178,14 @@
help_info[i].description );
exit( 0 );
- }
+ }
+ /* asking for version? */
+ if ( ( strncmp( argv[1], "-V", 2 ) == 0 ) ||
+ ( strncmp( argv[1],"--version",3 ) == 0 ) )
+ {
+ printf( "%s - %s\n",program_name,version );
+ exit( 0 );
+ }
}
/* create shared memory image and mutex */

View file

@ -0,0 +1,10 @@
--- sf.h.orig Mon Dec 21 08:18:55 1998
+++ sf.h Sat Nov 8 21:20:24 2003
@@ -17,6 +17,7 @@
typedef enum
{
+ c_VERSION = 'V',
c_VIEW_GEOMETRY = 'v',
c_CONTROL_GEOMETRY = 'c',
c_MINIMIZE = 'm',

View file

@ -0,0 +1,11 @@
--- sf_control.c.orig Mon Dec 21 08:18:55 1998
+++ sf_control.c Sat Nov 8 21:20:24 2003
@@ -266,7 +266,7 @@
static char xpm_filespec[MAX_FILESPEC+1] = { 0 };
static char design_filespec[MAX_FILESPEC+1] = { 0 };
-static char design_line = -1;
+static signed char design_line = -1;
static FILE* design_file = (FILE*)0;
/* ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ */

View file

@ -1,3 +1 @@
a snowflake image generator
WWW: http://www.infomatch.com/~donaldj/