Ports of GNU file-utilities.

PR:		ports/16638
Submitted by:	Udo Schweigert <ust@cert.siemens.de>
This commit is contained in:
SADA Kenji 2000-07-15 18:46:53 +00:00
parent 1e718f157c
commit ff846e2db8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30671
6 changed files with 122 additions and 0 deletions

View file

@ -0,0 +1,26 @@
# New ports collection makefile for: GNU fileutils
# Date created: Mon Jun 5 22:42:27 CEST 2000
# Whom: ust@cert.siemens.de
#
# $FreeBSD$
#
PORTNAME= fileutils
PORTVERSION= 4.0
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= fileutils
MAINTAINER= ust@cert.siemens.de
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g
MAN1= gchgrp.1 gchmod.1 gchown.1 gcp.1 gdd.1 gdf.1 gdir.1 \
gdircolors.1 gdu.1 ginstall.1 gln.1 gls.1 gmkdir.1 gmkfifo.1 \
gmknod.1 gmv.1 grm.1 grmdir.1 gsync.1 gtouch.1 gvdir.1
post-install:
install-info ${PREFIX}/info/fileutils.info ${PREFIX}/info/dir
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (fileutils-4.0.tar.gz) = 082ab37b7f37c00e768b04e37bc736be

View file

@ -0,0 +1,26 @@
--- doc/Makefile.in.orig Sat Nov 14 16:46:10 1998
+++ doc/Makefile.in Thu Feb 10 16:08:46 2000
@@ -211,23 +211,8 @@
else : ; fi; \
done; \
done
- @$(POST_INSTALL)
- @if $(SHELL) -c 'install-info --version | sed 1q | fgrep -s -v -i debian' >/dev/null 2>&1; then \
- for file in $(INFO_DEPS); do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
- done; \
- else : ; fi
uninstall-info:
- $(PRE_UNINSTALL)
- @if $(SHELL) -c 'install-info --version | sed 1q | fgrep -s -v -i debian' >/dev/null 2>&1; then \
- ii=yes; \
- else ii=; fi; \
- for file in $(INFO_DEPS); do \
- test -z "$ii" \
- || install-info --info-dir=$(DESTDIR)$(infodir) --remove $$file; \
- done
@$(NORMAL_UNINSTALL)
for file in $(INFO_DEPS); do \
(cd $(DESTDIR)$(infodir) && rm -f $$file $$file-[0-9] $$file-[0-9][0-9]); \

View file

@ -0,0 +1 @@
GNU version of file utilities

View file

@ -0,0 +1 @@
This directory contains the release of GNU fileutils.

View file

@ -0,0 +1,67 @@
bin/gchgrp
bin/gchmod
bin/gchown
bin/gcp
bin/gdd
bin/gdf
bin/gdir
bin/gdircolors
bin/gdu
bin/ginstall
bin/gln
bin/gls
bin/gmkdir
bin/gmkfifo
bin/gmknod
bin/gmv
bin/grm
bin/grmdir
bin/gsync
bin/gtouch
bin/gvdir
@unexec install-info --quiet --delete %D/info/fileutils.info %D/info/dir
info/fileutils.info
@exec install-info %D/info/fileutils.info %D/info/dir
share/locale/cs/LC_MESSAGES/fileutils.mo
share/locale/de/LC_MESSAGES/fileutils.mo
share/locale/el/LC_MESSAGES/fileutils.mo
share/locale/es/LC_MESSAGES/fileutils.mo
share/locale/fr/LC_MESSAGES/fileutils.mo
share/locale/ko/LC_MESSAGES/fileutils.mo
share/locale/nl/LC_MESSAGES/fileutils.mo
share/locale/no/LC_MESSAGES/fileutils.mo
share/locale/pl/LC_MESSAGES/fileutils.mo
share/locale/pt/LC_MESSAGES/fileutils.mo
share/locale/ru/LC_MESSAGES/fileutils.mo
share/locale/sk/LC_MESSAGES/fileutils.mo
share/locale/sl/LC_MESSAGES/fileutils.mo
share/locale/sv/LC_MESSAGES/fileutils.mo
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/de 2>/dev/null || true
@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/es 2>/dev/null || true
@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/fr 2>/dev/null || true
@unexec rmdir %D/share/locale/ko/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ko 2>/dev/null || true
@unexec rmdir %D/share/locale/nl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/nl 2>/dev/null || true
@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/no 2>/dev/null || true
@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pl 2>/dev/null || true
@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pt 2>/dev/null || true
@unexec rmdir %D/share/locale/ru/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ru 2>/dev/null || true
@unexec rmdir %D/share/locale/sk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sk 2>/dev/null || true
@unexec rmdir %D/share/locale/sl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sl 2>/dev/null || true
@unexec rmdir %D/share/locale/sv/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sv 2>/dev/null || true
@unexec rmdir %D/share/locale 2>/dev/null || true