Add hk_classes,

C++ library which allows rapid development of database applications.

Note: hk_classes works with mysql, postgresql und ODBC, but this port only
supports mysql at the moment.

Prodded by: 	enoal <sreco@xmission.com>
PR:		41380
This commit is contained in:
Tilman Keskinoz 2003-10-31 12:38:30 +00:00
parent aaa48e0ef8
commit ffa94017d6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92707
7 changed files with 117 additions and 0 deletions

View file

@ -42,6 +42,7 @@
SUBDIR += gqlplus
SUBDIR += grass
SUBDIR += gtksql
SUBDIR += hk_classes
SUBDIR += java-sqlrelay
SUBDIR += jdb
SUBDIR += jdbc-oracle816

View file

@ -0,0 +1,30 @@
# New ports collection makefile for: hk_classes
# Date created: 25 July 2002
# Whom: arved
#
# $FreeBSD$
PORTNAME= hk_classes
PORTVERSION= 0.6.1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hk-classes
MAINTAINER= ports@FreeBSD.org
COMMENT= "C++ Library for rapid development of database applications"
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
mysqlclient.10:${PORTSDIR}/databases/mysql323-client
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
-with-mysql-dir=${LOCALBASE} \
--with-mysql-incdir=${LOCALBASE}/include/mysql
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (hk_classes-0.6.1.tar.gz) = e376aaf0e8f266a4b7aa00b16349ae73

View file

@ -0,0 +1,16 @@
--- Makefile.in.orig Fri Oct 31 12:42:20 2003
+++ Makefile.in Fri Oct 31 12:42:44 2003
@@ -562,11 +562,11 @@
install-data-hook:
- echo ; echo ; echo "**********************************************"; echo ; \
+ @echo ; echo ; echo "**********************************************"; echo ; \
if @NODRIVER@ ;then echo "W A R N I N G !!!!" ; \
echo "No database driver installed! It makes no sense to run " ; echo "hk_classes without a database driver."; echo "Make sure that you have one of the following SQL databases." ; echo ; echo "Existing drivers are: @POSSIBLE_DRIVERS@" ; echo ; echo "Then re-configure and re-make this package." ;\
echo;echo "If you are sure the database is installed, but you still see this message,"; echo "check your installation. Probably you haven't installed your distribution's ";echo "development package for this database. For Mysql it is called ";echo "mysql-devel (the exact name is distribution specific)";\
- else echo "The following drivers are installed:"; echo "@DRIVERSDIR@" ;fi;echo; if test "x@HKPYTHONDIR@" == "xpython" ; then echo "Python support is installed" ; else echo "No Python support";fi;echo ; echo "I wish you much fun";echo ; echo "Horst Knorr <hk_classes@knoda.org>"; echo; echo "**********************************************"; echo ;
+ else echo "The following drivers are installed:"; echo "@DRIVERSDIR@" ;fi;echo; if test x@HKPYTHONDIR@ = xpython ; then echo "Python support is installed" ; else echo "No Python support";fi;echo ; echo "I wish you much fun";echo ; echo "Horst Knorr <hk_classes@knoda.org>"; echo; echo "**********************************************"; echo ;
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

View file

@ -0,0 +1,11 @@
--- hk_classes/hk_drivermanager.cpp.orig Fri Oct 31 12:14:16 2003
+++ hk_classes/hk_drivermanager.cpp Fri Oct 31 12:14:25 2003
@@ -141,7 +141,7 @@
{
if (interactive)
{
- char* e=dlerror();
+ const char* e=dlerror();
hk_string error=hk_translate("Unknown reason");
if (e) error=e;
hk_string w=hk_translate("Database driver '%DRIVER%' could not be loaded.\nReason: ")+error;

View file

@ -0,0 +1,10 @@
hk_classes is C++ library which allows rapid development of database
applications with all features a modern database application should
have like forms an reports.
hk_classes is database and GUI independent.
In combination with hk_kdeclasses it supports the rapid development
of database applications for KDE.
Author: Horst Knorr <hk_classes@knorrnet.de>
WWW: http://hk-classes.sourceforge.net/

View file

@ -0,0 +1,48 @@
include/hk_classes/hk_string.h
include/hk_classes/hk_database.h
include/hk_classes/hk_connection.h
include/hk_classes/hk_datasource.h
include/hk_classes/hk_column.h
include/hk_classes/hk_class.h
include/hk_classes/hk_definitions.h
include/hk_classes/hk_storagedatasource.h
include/hk_classes/hk_storagecolumn.h
include/hk_classes/hk_data.h
include/hk_classes/hk_visible.h
include/hk_classes/hk_dsvisible.h
include/hk_classes/hk_dsdatavisible.h
include/hk_classes/hk_dsmodevisible.h
include/hk_classes/hk_actionquery.h
include/hk_classes/hk_dsgrid.h
include/hk_classes/hk_dsgridcolumn.h
include/hk_classes/hk_datetime.h
include/hk_classes/hk_classes.h
include/hk_classes/hk_label.h
include/hk_classes/hk_report.h
include/hk_classes/hk_reportsectionpair.h
include/hk_classes/hk_reportsection.h
include/hk_classes/hk_reportdata.h
include/hk_classes/hk_reportutils.h
include/hk_classes/hk_importcsv.h
include/hk_classes/hk_form.h
include/hk_classes/hk_presentation.h
include/hk_classes/hk_dslineedit.h
include/hk_classes/hk_dsboolean.h
include/hk_classes/hk_dscombobox.h
include/hk_classes/hk_dsmemo.h
include/hk_classes/hk_button.h
include/hk_classes/hk_dsrowselector.h
include/hk_classes/hk_dbvisible.h
include/hk_classes/hk_drivermanager.h
include/hk_classes/hk_colour.h
include/hk_classes/hk_font.h
include/hk_classes/hk_interpreter.h
lib/hk_classes/drivers/libhk_mysqldriver.so.3
lib/hk_classes/drivers/libhk_mysqldriver.so
lib/hk_classes/drivers/libhk_mysqldriver.la
lib/hk_classes/libhk_classes.so.5
lib/hk_classes/libhk_classes.la
lib/hk_classes/libhk_classes.so
@dirrm include/hk_classes
@dirrm lib/hk_classes/drivers
@dirrm lib/hk_classes