- Update to 1.9.1
- Take maintainship
This commit is contained in:
parent
4f994315e8
commit
ffaa71bb09
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219387
4 changed files with 9 additions and 28 deletions
|
@ -6,21 +6,18 @@
|
|||
#
|
||||
|
||||
PORTNAME= kawa
|
||||
PORTVERSION= 1.8
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.9.1
|
||||
CATEGORIES= lang scheme java
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= kawa
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= gahr@FreeBSD.org
|
||||
COMMENT= Java-based Scheme implementation
|
||||
|
||||
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
|
||||
|
||||
USE_JAVA= yes
|
||||
JAVA_VERSION= 1.2+
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-kawa-frontend --program-prefix=''
|
||||
CONFIGURE_ARGS= --enable-kawa-frontend \
|
||||
--with-java-source=${JAVA_PORT_VERSION} \
|
||||
|
||||
MAN1= kawa.1 qexo.1
|
||||
INFO= kawa kawa-tour
|
||||
|
@ -29,9 +26,8 @@ INFO= kawa kawa-tour
|
|||
|
||||
pre-patch:
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's|sed |gsed |g;' \
|
||||
-e 's|JAR = jar|JAR = ${JAR}|g;'
|
||||
@${REINPLACE_CMD} -e 's|{JAVAC-javac}|{JAVAC-${JAVAC}}|g;' \
|
||||
-e 's|{JAVA-java}|{JAVA-${JAVA}}|g;' ${WRKSRC}/configure
|
||||
-e 's|{JAVA-java}|{JAVA-${JAVA}}|g; 4055d;' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (kawa-1.8.tar.gz) = d3f33eccb77dd7dc6805fb81b72ebb2a
|
||||
SHA256 (kawa-1.8.tar.gz) = bc3ab0cd7f80524d90ef57c7c6d0430890969b511cd2bb60eb480a68fd8761bf
|
||||
SIZE (kawa-1.8.tar.gz) = 1944341
|
||||
MD5 (kawa-1.9.1.tar.gz) = 8a1cc2d67127392f6f3f180d53800725
|
||||
SHA256 (kawa-1.9.1.tar.gz) = 590da119e1a130c059cdb08dcf0a17a2d27f14020bd51b99a8318554b57a77d9
|
||||
SIZE (kawa-1.9.1.tar.gz) = 1973504
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- bin/kawapath.c.orig
|
||||
+++ bin/kawapath.c
|
||||
@@ -15,8 +15,8 @@
|
||||
const char *path = getenv("KAWALIB");
|
||||
if (path == NULL)
|
||||
{
|
||||
- path = kawalib;
|
||||
const char *rp = progname == NULL ? NULL : strrchr(progname, '/');
|
||||
+ path = kawalib;
|
||||
if (rp != NULL)
|
||||
{
|
||||
/* If kawa is executed "in place" as $builddir/bin/kawa
|
|
@ -1,5 +1,5 @@
|
|||
bin/cgi-servlet
|
||||
bin/kawa
|
||||
bin/qexo
|
||||
share/java/kawa-1.8.jar
|
||||
share/java/kawa-1.9.1.jar
|
||||
share/java/kawa.jar
|
||||
|
|
Loading…
Reference in a new issue