[NEW] databases/py3-bsddb3: Python3 version of databases/py-bsddb3

- Assign MAINTAINER to submitter

PR:		207033
Submitted by:	woodsb02@gmail.com
This commit is contained in:
Muhammad Moinur Rahman 2016-02-19 22:51:22 +00:00
parent 741f80ecca
commit ffaef68ad2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=409213
6 changed files with 120 additions and 0 deletions

View file

@ -787,6 +787,7 @@
SUBDIR += py-tarantool
SUBDIR += py-umemcache
SUBDIR += py-whisper
SUBDIR += py3-bsddb3
SUBDIR += py33-gdbm
SUBDIR += py33-sqlite3
SUBDIR += py34-gdbm

View file

@ -0,0 +1,37 @@
# Created by: Ben Woods <woodsb02@gmail.com>
# $FreeBSD$
PORTNAME= bsddb3
PORTVERSION= 6.1.1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= woodsb02@gmail.com
COMMENT= Python extension module for BerkeleyDB 3 and 4
LICENSE= BSD3CLAUSE
USE_BDB= yes
USES= python:3
USE_PYTHON= distutils autoplist
PYDISTUTILS_CONFIGUREARGS=--libs="-l${BDB_LIB_NAME}" --berkeley-db=${LOCALBASE}
PYDISTUTILS_BUILDARGS= --libs="-l${BDB_LIB_NAME}" --berkeley-db=${LOCALBASE}
PYDISTUTILS_INSTALLARGS=-c -O1 --prefix=${PREFIX} --berkeley-db=${LOCALBASE}
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
post-patch:
${REINPLACE_CMD} 's,%%DBVERSION%%,${BDB_LIB_NAME},g' ${WRKSRC}/setup2.py ${WRKSRC}/setup3.py
${REINPLACE_CMD} 's,<db\.h>,<${BDB_INCLUDE_DIR}/db.h>,' ${WRKSRC}/Modules/bsddb.h
${REINPLACE_CMD} 's,%%BDB_INCLUDE_DIR%%,${BDB_INCLUDE_DIR},' ${WRKSRC}/setup2.py ${WRKSRC}/setup3.py
${REINPLACE_CMD} 's,%%BDB_LIB_NAME%%,${BDB_LIB_NAME},' ${WRKSRC}/setup3.py
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/bsddb3/_pybsddb.so
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (bsddb3-6.1.1.tar.gz) = 6f21b0252125c07798d784c164ef135ad153d226c01b290258ee1c5b9e7c4dd3
SIZE (bsddb3-6.1.1.tar.gz) = 450571

View file

@ -0,0 +1,35 @@
--- setup2.py.orig 2016-02-08 21:14:26 UTC
+++ setup2.py
@@ -81,11 +81,7 @@ if (sys.version_info[0] < 3) and (sys.ve
category=DeprecationWarning)
-try :
- from setuptools import setup, Extension
-except :
- from distutils.core import setup, Extension
-
+from distutils.core import setup, Extension
from distutils.dep_util import newer
import distutils.ccompiler
@@ -288,8 +284,8 @@ if os.name == 'posix':
incdir = os.path.join(BERKELEYDB_DIR, 'include')
if not libdir:
libdir = os.path.join(BERKELEYDB_DIR, 'lib')
- if not '-ldb' in LIBS:
- libname = [dblib]
+ if not '-l%%DBVERSION%%' in LIBS:
+ libname = ['%%DBVERSION%%']
else:
if debug: print "LIBS already contains '-ldb' not adding our own", "'-l"+dblib+"'"
libname = []
@@ -328,7 +324,7 @@ if os.name == 'posix':
# read db.h to figure out what version of Berkeley DB this is
ver = None
- with open(os.path.join(incdir, 'db.h'), 'r') as f :
+ with open('%%BDB_INCLUDE_DIR%%/db.h', 'r') as f :
db_h_lines = f.readlines()
db_ver_re = re.compile(
r'^#define\s+DB_VERSION_STRING\s.*Berkeley DB (\d+\.\d+).*')

View file

@ -0,0 +1,35 @@
--- setup3.py.orig 2016-02-08 21:18:47 UTC
+++ setup3.py
@@ -81,11 +81,7 @@ if (sys.version_info[0] < 3) and (sys.ve
category=DeprecationWarning)
-try :
- from setuptools import setup, Extension
-except :
- from distutils.core import setup, Extension
-
+from distutils.core import setup, Extension
from distutils.dep_util import newer
import distutils.ccompiler
@@ -288,8 +284,8 @@ if os.name == 'posix':
incdir = os.path.join(BERKELEYDB_DIR, 'include')
if not libdir:
libdir = os.path.join(BERKELEYDB_DIR, 'lib')
- if not '-ldb' in LIBS:
- libname = [dblib]
+ if not '-l%%BDB_LIB_NAME%%' in LIBS:
+ libname = ['%%BDB_LIB_NAME%%']
else:
if debug: print("LIBS already contains '-ldb' not adding our own", "'-l"+dblib+"'")
libname = []
@@ -328,7 +324,7 @@ if os.name == 'posix':
# read db.h to figure out what version of Berkeley DB this is
ver = None
- with open(os.path.join(incdir, 'db.h'), 'r') as f :
+ with open('%%BDB_INCLUDE_DIR%%/db.h', 'r') as f :
db_h_lines = f.readlines()
db_ver_re = re.compile(
r'^#define\s+DB_VERSION_STRING\s.*Berkeley DB (\d+\.\d+).*')

View file

@ -0,0 +1,10 @@
This module provides a nearly complete wrapping of the Sleepycat C API
for the Database Environment, Database, Cursor, and Transaction
objects, and each of these is exposed as a Python Type in the
bsddb3.db module. The database objects can use different access
methods, btree, hash, recno, and queue. For the first time all of
these are fully supported in the Python wrappers. Please see the
document in developers' web site for more details on the types and
methods provided.
WWW: http://www.jcea.es/programacion/pybsddb.htm