- Upgrade to 0.92.
- unbreak the examples. Approved by: mat (implicit).
This commit is contained in:
parent
93ed109035
commit
ffbb864d7d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106057
5 changed files with 101 additions and 5 deletions
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gambas
|
||||
PORTVERSION= 0.91
|
||||
PORTVERSION= 0.92
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://gambas.sourceforge.net/
|
||||
|
||||
|
@ -19,7 +19,7 @@ RUN_DEPENDS= pgrep:${PORTSDIR}/sysutils/pkill
|
|||
USE_KDELIBS_VER= 3
|
||||
USE_GETTEXT= yes
|
||||
USE_BZIP2= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_LIBTOOL_VER= 13
|
||||
LIBTOOLFILES= configure libltdl/configure
|
||||
LIBTOOLFLAGS= # none
|
||||
USE_GMAKE= yes
|
||||
|
@ -105,5 +105,7 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e "s|# FreeBSD-Doc-Comment||" ${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile.in
|
||||
@${RM} ${WRKSRC}/examples/Database/DataReportExample/Fconn.class.orig \
|
||||
${WRKSRC}/examples/Database/DataReportExample/Fmain.class.orig
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gambas-0.91.tar.bz2) = de4f38111c8657332670bb241a1b1f56
|
||||
SIZE (gambas-0.91.tar.bz2) = 2711923
|
||||
MD5 (gambas-0.92.tar.bz2) = 06641baa8c0405a9075088690eb30a67
|
||||
SIZE (gambas-0.92.tar.bz2) = 2735305
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
--- ./examples/Database/DataReportExample/Fconn.class.orig Mon Feb 23 17:31:34 2004
|
||||
+++ ./examples/Database/DataReportExample/Fconn.class Sat Apr 3 17:29:08 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
END
|
||||
|
||||
PUBLIC SUB ginput_KeyPress()
|
||||
- IF key.code=key.enter OR key.code=key.return THEN
|
||||
+ IF Key.Code=Key.Enter OR Key.Code=Key.Return THEN
|
||||
SELECT CASE LAST.tag
|
||||
CASE 1
|
||||
textbox2.setfocus
|
||||
@@ -75,4 +75,4 @@
|
||||
|
||||
CATCH
|
||||
Message.Error(Error.Text)
|
||||
-END
|
||||
\ No newline at end of file
|
||||
+END
|
|
@ -0,0 +1,62 @@
|
|||
--- ./examples/Database/DataReportExample/Fmain.class.orig Sun Mar 14 11:01:59 2004
|
||||
+++ ./examples/Database/DataReportExample/Fmain.class Sat Apr 3 17:26:02 2004
|
||||
@@ -45,7 +45,7 @@
|
||||
WITH mglobal
|
||||
SELECT CASE LAST.tag
|
||||
CASE 1 'textbox ID
|
||||
- a=.chk (textbox1, key.code, "num")
|
||||
+ a=.chk (textbox1, Key.Code, "num")
|
||||
SELECT CASE a
|
||||
CASE 1
|
||||
ME.close
|
||||
@@ -53,7 +53,7 @@
|
||||
STOP EVENT
|
||||
END SELECT
|
||||
|
||||
- IF key.code=key.enter OR key.code=key.return THEN
|
||||
+ IF Key.Code=Key.enter OR Key.Code=Key.return THEN
|
||||
.rs=.db.exec("select name from user where id='" & textbox1.text & "'")
|
||||
IF .rs.count<>0 THEN
|
||||
textbox2.text=.rs!name
|
||||
@@ -64,7 +64,7 @@
|
||||
END IF
|
||||
|
||||
CASE 2 'textbox Name
|
||||
- a=.chk (textbox2, key.code)
|
||||
+ a=.chk (textbox2, Key.Code)
|
||||
SELECT CASE a
|
||||
CASE 1
|
||||
ME.close
|
||||
@@ -72,7 +72,7 @@
|
||||
STOP EVENT
|
||||
END SELECT
|
||||
|
||||
- IF key.code=key.enter OR key.code=key.return THEN
|
||||
+ IF Key.Code=Key.enter OR Key.Code=Key.return THEN
|
||||
textbox1.setfocus
|
||||
.rs = .db.exec("select * from user where id='" & textbox1.text & "'")
|
||||
IF .rs.count =0 THEN
|
||||
@@ -118,11 +118,11 @@
|
||||
END
|
||||
|
||||
PUBLIC SUB TableView1_KeyRelease()
|
||||
- SELECT CASE key.code
|
||||
- CASE key.Enter, key.Return
|
||||
+ SELECT CASE Key.Code
|
||||
+ CASE Key.Enter, Key.Return
|
||||
tableview1_click()
|
||||
|
||||
- CASE key.Escape
|
||||
+ CASE Key.Escape
|
||||
ME.close
|
||||
END SELECT
|
||||
END
|
||||
@@ -142,7 +142,7 @@
|
||||
END
|
||||
|
||||
PUBLIC SUB gbtn_KeyPress()
|
||||
- IF key.code=key.escape THEN ME.close
|
||||
+ IF Key.Code=Key.Escape THEN ME.close
|
||||
END
|
||||
|
||||
PUBLIC SUB header(prn AS Boolean)
|
|
@ -6014,8 +6014,20 @@ gambas/lib/lib.gb.vb.so.0
|
|||
%%PORTDOCS%%%%EXAMPLESDIR%%/Basic/Timer/FTimer.class
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Basic/Timer/FTimer.form
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Basic/Timer/Timer
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/.gambas/FREQUEST
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/.gambas/FMAIN
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/.kdbgrc.gbx
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/.project
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/Database
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/FMain.class
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/FMain.form
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/FRequest.class
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/Database/FRequest.form
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.gambas/FABOUT
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.gambas/FCONN
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.gambas/FMAIN
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.gambas/FPREVIEW
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.gambas/MGLOBAL
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.kdbgrc.gbx
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/.project
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/DataReportExample
|
||||
|
@ -6028,7 +6040,6 @@ gambas/lib/lib.gb.vb.so.0
|
|||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/Fpreview.class
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/Fpreview.form
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/Mglobal.module
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/gbc.core
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/pic/button_cance.png
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/pic/button_ok.png
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Database/DataReportExample/pic/empty.png
|
||||
|
@ -6205,6 +6216,9 @@ gambas/lib/lib.gb.vb.so.0
|
|||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Evaluator/.lang
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Evaluator/.gambas
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Evaluator
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Database/Database/.gambas
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Database/Database/.lang
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Database/Database
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Database/DataReportExample/pic
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Database/DataReportExample/.gambas
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Database/DataReportExample
|
||||
|
|
Loading…
Reference in a new issue