graphics/glslang: update to 13.0.0

Changes:	https://github.com/KhronosGroup/glslang/releases/tag/13.0.0
Reported by:	GitHub (watch releases)
This commit is contained in:
Jan Beich 2023-08-24 01:24:25 +02:00
parent 2f6108e208
commit ffbcda74cb
3 changed files with 4 additions and 15 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= glslang
DISTVERSION= 12.3.1
DISTVERSION= 13.0.0
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1689886431
SHA256 (KhronosGroup-glslang-12.3.1_GH0.tar.gz) = a57836a583b3044087ac51bb0d5d2d803ff84591d55f89087fc29ace42a8b9a8
SIZE (KhronosGroup-glslang-12.3.1_GH0.tar.gz) = 3718998
TIMESTAMP = 1692833065
SHA256 (KhronosGroup-glslang-13.0.0_GH0.tar.gz) = bcda732434f829aa74414ea0e06d329ec8ac28637c38a0de45e17c8fd25a4715
SIZE (KhronosGroup-glslang-13.0.0_GH0.tar.gz) = 3710806

View file

@ -1,11 +0,0 @@
--- StandAlone/CMakeLists.txt.orig 2023-07-20 20:53:51 UTC
+++ StandAlone/CMakeLists.txt
@@ -121,7 +121,7 @@ if(ENABLE_GLSLANG_INSTALL)
# Create the same symlink at install time
install(CODE "execute_process( \
COMMAND ${CMAKE_COMMAND} -E ${link_method} $<TARGET_FILE_NAME:glslang-standalone> ${legacy_glslang_name} \
- WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})")
+ WORKING_DIRECTORY \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})")
if(ENABLE_SPVREMAPPER)
install(TARGETS spirv-remap EXPORT glslang-targets)