- Back out of 1.9.6 and back down to 1.3.4 since ffi doesn't build on !i386
* Kept glib2 instead of backing down to glib1 Approved by: portmgr (marcus) Reported by: pointyhat via kris
This commit is contained in:
parent
a0a4a2fb88
commit
fff9f6cef3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=175380
8 changed files with 92 additions and 98 deletions
|
@ -7,10 +7,11 @@
|
|||
# $MCom: ports/devel/g-wrap/Makefile,v 1.4 2006/09/12 21:27:18 ahze Exp $
|
||||
|
||||
PORTNAME= g-wrap
|
||||
PORTVERSION= 1.9.6
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.3.4
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= devel scheme
|
||||
MASTER_SITES= SAVANNAH
|
||||
MASTER_SITES= http://www.gnucash.org/pub/g-wrap/source/ \
|
||||
http://people.freebsd.org/~sobomax/
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A tool for exporting C libraries into Scheme interpreters
|
||||
|
@ -21,22 +22,13 @@ RUN_DEPENDS= slib-guile>0:${PORTSDIR}/lang/slib-guile
|
|||
|
||||
INFO= g-wrap
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= glib20 gnomehack
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|"glib"|"glib-2.0"|' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
pre-install:
|
||||
@${REINPLACE_CMD} -e 's|libffi||' ${WRKSRC}/${MAKEFILE}
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/include/g-wrap/ffi
|
||||
.for f in ffi.h ffitarget.h
|
||||
${INSTALL_DATA} ${WRKSRC}/libffi/include/${f} ${PREFIX}/include/g-wrap/ffi
|
||||
.endfor
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ENV+= GW_GLIB_CONFIG="${TRUE}" \
|
||||
CPPFLAGS="`${LOCALBASE}/bin/pkg-config --cflags glib-2.0`" \
|
||||
LIBS="`${LOCALBASE}/bin/pkg-config --libs glib-2.0`"
|
||||
MAKE_ENV+= GUILE_LOAD_PATH=${WRKSRC}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (g-wrap-1.9.6.tar.gz) = 4d83964f51376500eedced538c1620cb
|
||||
SHA256 (g-wrap-1.9.6.tar.gz) = ddb0e31d40581402d6d7045cce7cdc79e0bc0627831a4b12012f45703446d311
|
||||
SIZE (g-wrap-1.9.6.tar.gz) = 826045
|
||||
MD5 (g-wrap-1.3.4.tar.gz) = bf29b8b563cc27d9f7fd90a6243653aa
|
||||
SHA256 (g-wrap-1.3.4.tar.gz) = bb9fa9b7b6b2a11899d98d730cf5970179bbf942fd763eda13b7b541278adee4
|
||||
SIZE (g-wrap-1.3.4.tar.gz) = 403570
|
||||
|
|
11
devel/g-wrap/files/patch-Makefile.in
Normal file
11
devel/g-wrap/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Thu Nov 7 23:40:46 2002
|
||||
+++ Makefile.in Tue Feb 4 20:43:51 2003
|
||||
@@ -144,7 +144,7 @@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-SUBDIRS = doc rpm bin g-wrap example test
|
||||
+SUBDIRS = doc rpm bin g-wrap example
|
||||
|
||||
guilemoduledir = @GUILEMODDIR@
|
||||
guilemodule_DATA = @GUILEMOD_TARGET@
|
13
devel/g-wrap/files/patch-ab
Normal file
13
devel/g-wrap/files/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- doc/g-wrap.texi.orig Thu Jun 22 06:42:12 2000
|
||||
+++ doc/g-wrap.texi Sat Jul 15 12:15:38 2000
|
||||
@@ -2,6 +2,10 @@
|
||||
@c %**start of header
|
||||
@setfilename g-wrap.info
|
||||
@settitle g-wrap
|
||||
+@dircategory Scheme Programming
|
||||
+@direntry
|
||||
+* g-wrap: (g-wrap). A tool for exporting C libraries into Scheme interpreters.
|
||||
+@end direntry
|
||||
@setchapternewpage on
|
||||
@c Choices for setchapternewpage are {on,off,odd}.
|
||||
@paragraphindent 0
|
11
devel/g-wrap/files/patch-g-wrap_Makefile.in
Normal file
11
devel/g-wrap/files/patch-g-wrap_Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- g-wrap/Makefile.in.orig Tue Feb 4 20:45:49 2003
|
||||
+++ g-wrap/Makefile.in Tue Feb 4 20:46:00 2003
|
||||
@@ -197,7 +197,7 @@
|
||||
|
||||
|
||||
#AM_CFLAGS = -O2 -g -Wall -Wno-uninitialized -Werror
|
||||
-AM_CFLAGS = -O2 -g -Wall -Werror \
|
||||
+AM_CFLAGS = -Wall -Werror \
|
||||
${GW_GLIB_CFLAGS_ADD} \
|
||||
${GW_GUILE_GTK_CFLAGS_ADD}
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
--- guile/g-wrap-2.0-guile.pc.in.orig Mon Oct 11 06:32:16 2004
|
||||
+++ guile/g-wrap-2.0-guile.pc.in Tue Sep 12 17:10:41 2006
|
||||
@@ -5,9 +5,10 @@
|
||||
libdir=@libdir@
|
||||
includedir=@includedir@
|
||||
module_directory=@GUILEMODDIR@
|
||||
+ffiincludedir= @includedir@/g-wrap/ffi
|
||||
|
||||
Name: G-Wrap
|
||||
Description: A Guile wrapper generator
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -lgwrap-guile-runtime -lgwrap-core-runtime @GUILE_LDFLAGS@ @LIBFFI_LIBS_INSTALLED@
|
||||
-Cflags: @STD_CFLAGS@ -I${includedir} @GUILE_CFLAGS@ @LIBFFI_CFLAGS_INSTALLED@
|
||||
+Libs: -L/usr/local/lib/elf -L${libdir} -lgwrap-guile-runtime -lgwrap-core-runtime @GUILE_LDFLAGS@
|
||||
+Cflags: @STD_CFLAGS@ -I${includedir} -I${ffiincludedir} @GUILE_CFLAGS@ @LIBFFI_CFLAGS_INSTALLED@
|
|
@ -1,11 +0,0 @@
|
|||
--- libffi/configure.orig Tue Sep 12 17:01:51 2006
|
||||
+++ libffi/configure Tue Sep 12 17:02:19 2006
|
||||
@@ -3285,7 +3285,7 @@
|
||||
;;
|
||||
esac
|
||||
else
|
||||
- enable_shared=yes
|
||||
+ enable_shared=no # don't build shared lib (or conflict with gcc3*)
|
||||
fi;
|
||||
|
||||
# Check whether --enable-static or --disable-static was given.
|
|
@ -1,54 +1,47 @@
|
|||
bin/g-wrap-config
|
||||
include/g-wrap-wct.h
|
||||
include/g-wrap/core-runtime.h
|
||||
include/g-wrap/ffi-support.h
|
||||
include/g-wrap/ffi/ffi.h
|
||||
include/g-wrap/ffi/ffitarget.h
|
||||
include/g-wrap/guile-compatibility.h
|
||||
include/g-wrap/guile-runtime.h
|
||||
include/g-wrap/guile-wct.h
|
||||
lib/libgw-guile-gw-glib.a
|
||||
lib/libgw-guile-gw-glib.la
|
||||
lib/libgw-guile-gw-glib.so
|
||||
lib/libgw-guile-gw-glib.so.0
|
||||
lib/libgw-guile-standard.a
|
||||
lib/libgw-guile-standard.la
|
||||
lib/libgw-guile-standard.so
|
||||
lib/libgw-guile-standard.so.0
|
||||
lib/libgwrap-core-runtime.a
|
||||
lib/libgwrap-core-runtime.la
|
||||
lib/libgwrap-core-runtime.so
|
||||
lib/libgwrap-core-runtime.so.0
|
||||
lib/libgwrap-guile-runtime.a
|
||||
lib/libgwrap-guile-runtime.la
|
||||
lib/libgwrap-guile-runtime.so
|
||||
lib/libgwrap-guile-runtime.so.0
|
||||
libdata/pkgconfig/g-wrap-2.0-guile.pc
|
||||
share/guile/site/g-wrap.scm
|
||||
share/guile/site/g-wrap/c-types.scm
|
||||
share/guile/site/g-wrap/compat.scm
|
||||
share/guile/site/g-wrap/enumeration.scm
|
||||
share/guile/site/g-wrap/guile.scm
|
||||
share/guile/site/g-wrap/guile/ws/standard.scm
|
||||
share/guile/site/g-wrap/gw-glib-spec.scm
|
||||
share/guile/site/g-wrap/gw-glib.scm
|
||||
share/guile/site/g-wrap/gw-standard-spec.scm
|
||||
share/guile/site/g-wrap/gw-wct-spec.scm
|
||||
share/guile/site/g-wrap/gw-wct.scm
|
||||
share/guile/site/g-wrap/gw/standard.scm
|
||||
share/guile/site/g-wrap/rti.scm
|
||||
share/guile/site/g-wrap/simple-type.scm
|
||||
share/guile/site/g-wrap/util.scm
|
||||
share/guile/site/g-wrap/ws/standard.scm
|
||||
share/guile/site/srfi/srfi-34.scm
|
||||
share/guile/site/srfi/srfi-35.scm
|
||||
@dirrmtry share/guile/site/srfi
|
||||
@dirrmtry share/guile/site/g-wrap/ws
|
||||
@dirrmtry share/guile/site/g-wrap/gw
|
||||
@dirrmtry share/guile/site/g-wrap/guile/ws
|
||||
@dirrmtry share/guile/site/g-wrap/guile
|
||||
@dirrmtry share/guile/site/g-wrap
|
||||
@dirrmtry share/guile/site
|
||||
@dirrmtry share/guile
|
||||
@dirrm include/g-wrap/ffi
|
||||
include/g-wrap/g-wrap-compatibility.h
|
||||
include/g-wrap/g-wrap-glib.h
|
||||
include/g-wrap/g-wrap-wct.h
|
||||
lib/libgw-glib.a
|
||||
lib/libgw-glib.la
|
||||
lib/libgw-glib.so
|
||||
lib/libgw-glib.so.0
|
||||
lib/libgw-gtk.a
|
||||
lib/libgw-gtk.la
|
||||
lib/libgw-gtk.so
|
||||
lib/libgw-gtk.so.0
|
||||
lib/libgw-standard.a
|
||||
lib/libgw-standard.la
|
||||
lib/libgw-standard.so
|
||||
lib/libgw-standard.so.0
|
||||
lib/libgw-wct.a
|
||||
lib/libgw-wct.la
|
||||
lib/libgw-wct.so
|
||||
lib/libgw-wct.so.0
|
||||
lib/libgwrap-glib.a
|
||||
lib/libgwrap-glib.la
|
||||
lib/libgwrap-glib.so
|
||||
lib/libgwrap-glib.so.1
|
||||
lib/libgwrap-wct.a
|
||||
lib/libgwrap-wct.la
|
||||
lib/libgwrap-wct.so
|
||||
lib/libgwrap-wct.so.1
|
||||
share/aclocal/g-wrap.m4
|
||||
share/guile/g-wrap.scm
|
||||
share/guile/g-wrap/enumeration.scm
|
||||
share/guile/g-wrap/g-translate.scm
|
||||
share/guile/g-wrap/gtkobj.scm
|
||||
share/guile/g-wrap/gw-glib-spec.scm
|
||||
share/guile/g-wrap/gw-glib.scm
|
||||
share/guile/g-wrap/gw-gtk-spec.scm
|
||||
share/guile/g-wrap/gw-gtk.scm
|
||||
share/guile/g-wrap/gw-standard-spec.scm
|
||||
share/guile/g-wrap/gw-standard.scm
|
||||
share/guile/g-wrap/gw-wct-spec.scm
|
||||
share/guile/g-wrap/gw-wct.scm
|
||||
share/guile/g-wrap/output-file.scm
|
||||
share/guile/g-wrap/runtime.scm
|
||||
share/guile/g-wrap/simple-type.scm
|
||||
share/guile/g-wrap/sorting.scm
|
||||
@dirrm share/guile/g-wrap
|
||||
@dirrm include/g-wrap
|
||||
|
|
Loading…
Reference in a new issue