freebsd-ports/print/ghostscript7-x11/files/patch-src-idparam.c
Hiroki Sato 27470e1676 - Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base

   Installs Ghostscript binary, libgs, and related files.
   These ports do not depend on X11 libraries (i.e. x11* devices
   are not available).  USES=ghostscript will set dependency on
   one of them depending on GHOSTSCRIPT_DEFAULT.

   The default device is set to "display" or "bbox".

 * print/ghostscript{7,8,9,9-agpl}-x11

   Installs a shared library which provides X11 support to
   the installed Ghostscript binaries.  x11* devices will be
   enabled when the library is available.

   This depends on *-base (RUN_DEPENDS).  USES=ghostscript:x11
   will set dependency on one of them.

- Fix integer overflow reported as CVE-2015-3228.

- Update Uses/ghostscript.mk:

 * Add x11 keyword.  nox11 keyword is now obsolete.

 * Use packagename in *_DEPENDS line to prevent relationship between
   -base and -x11 packages from being broken.

- Fix x11/nox11 keyword and bump PORTREVISION in ports using
  USES=ghostscript to update dependency of pre-compiled packages.
2015-08-22 17:48:35 +00:00

21 lines
642 B
C

--- src/idparam.c.orig 2013-04-30 10:54:55.000000000 +0900
+++ src/idparam.c 2013-04-30 10:55:23.000000000 +0900
@@ -61,8 +61,7 @@
int maxval, int defaultval, int *pvalue)
{
ref *pdval;
- int code;
- long ival;
+ int code, ival;
if (pdict == 0 || dict_find_string(pdict, kstr, &pdval) <= 0) {
ival = defaultval;
@@ -349,7 +348,7 @@
} else {
if (!r_has_type(puniqueid, t_integer) ||
puniqueid->value.intval < 0 ||
- puniqueid->value.intval > 0xffffffL
+ puniqueid->value.intval > 0xffffff
)
return_error(e_rangecheck);
/* Apparently fonts created by Fontographer often have */