27470e1676
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
11 lines
338 B
C
11 lines
338 B
C
--- src/iref.h.orig 2013-04-30 11:13:29.000000000 +0900
|
|
+++ src/iref.h 2013-04-30 11:13:41.000000000 +0900
|
|
@@ -441,7 +441,7 @@
|
|
#define r_set_ptr(rp,ptr) ((rp)->value.pstruct = (obj_header_t *)(ptr))
|
|
|
|
union v { /* name the union to keep gdb happy */
|
|
- long intval;
|
|
+ int intval;
|
|
ushort boolval;
|
|
float realval;
|
|
ulong saveid;
|