8f469595ae
Contains fixes for a bug which causes segmentation fault to the c-icap server PR: ports/98903 Submitted by: maintainer
41 lines
1.9 KiB
Text
41 lines
1.9 KiB
Text
--- configure.bak Mon Jun 12 22:20:15 2006
|
|
+++ configure Thu Jun 15 15:34:49 2006
|
|
@@ -19441,7 +19441,7 @@
|
|
THREADS_LDADD="-lpthread"
|
|
THREADS_LDFLAGS=""
|
|
;;
|
|
- freebsd5.*)
|
|
+ freebsd4.*)
|
|
## If I understand how all those threading models works correctly
|
|
## in FreeBSD I will make an option in configure script
|
|
## --with-freebsd-threads={c_r,pthreads,linuxthreads,thr}
|
|
@@ -19454,9 +19454,9 @@
|
|
# THREADS_LDADD="-llthread -lgcc_r"
|
|
# THREADS_LDFLAGS="-L/usr/local/lib"
|
|
|
|
-## FreeBSD Standard threads
|
|
+## FreeBSD 4.x Standard threads
|
|
CFLAGS="-pthread -D_THREAD_SAFE $CFLAGS"
|
|
- THREADS_LDADD="-XCClinker -lc_r"
|
|
+ THREADS_LDADD="-lc_r"
|
|
THREADS_LDFLAGS=""
|
|
|
|
## 1:1 threads
|
|
@@ -21574,7 +21574,7 @@
|
|
fi
|
|
|
|
|
|
- ac_config_files="$ac_config_files Makefile c-icap.conf services/Makefile services/echo/Makefile services/url_check/Makefile services/clamav/Makefile modules/Makefile"
|
|
+ ac_config_files="$ac_config_files Makefile c-icap.conf.default services/Makefile services/echo/Makefile services/url_check/Makefile services/clamav/Makefile modules/Makefile"
|
|
cat >confcache <<\_ACEOF
|
|
# This file is a shell script that caches the results of configure
|
|
# tests run on this system so they can be shared between configure
|
|
@@ -22160,7 +22160,7 @@
|
|
case "$ac_config_target" in
|
|
# Handling of arguments.
|
|
"Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
|
|
- "c-icap.conf" ) CONFIG_FILES="$CONFIG_FILES c-icap.conf" ;;
|
|
+ "c-icap.conf.default" ) CONFIG_FILES="$CONFIG_FILES c-icap.conf.default" ;;
|
|
"services/Makefile" ) CONFIG_FILES="$CONFIG_FILES services/Makefile" ;;
|
|
"services/echo/Makefile" ) CONFIG_FILES="$CONFIG_FILES services/echo/Makefile" ;;
|
|
"services/url_check/Makefile" ) CONFIG_FILES="$CONFIG_FILES services/url_check/Makefile" ;;
|