freebsd-ports/games/gnushogi/files/patch-aa
2001-04-30 04:44:02 +00:00

53 lines
1.9 KiB
Text

--- src/Makefile.orig Wed May 24 07:05:26 1995
+++ src/Makefile Sun Apr 29 21:39:00 2001
@@ -41,22 +41,22 @@
DIST= ../README-$(VERS) ../doc ../misc ../src
# Installation directory
-prefix=/usr/local
+#prefix=/usr/local
#prefix=/public/projects/shogi
# Change these to something less transitory, like /usr/games, and then
# compile. Ask your system admin / unix guru to put gnushogi.{hsh,lng,tbk}
# in $(LIBDIR).
# Where the binaries live.
-BINDIR= $(prefix)/games
+BINDIR= $(prefix)/bin
#BINDIR=/public/projects/shogi/bin
# Where language description, our book, and the persistent hash live.
-LIBDIR= $(prefix)/games/lib/gnushogi
+LIBDIR= $(prefix)/share/gnushogi
#LIBDIR=/public/projects/shogi/lib
# Distribution directory
-DISTDIR=/public/projects/shogi
+#DISTDIR=/public/projects/shogi
# Programs being distributed
PROGS=gnushogi-$(VERS)
@@ -76,7 +76,7 @@
#CC= c89 $(OPT) $(GENOPT)
# Use this if you are lucky enough to have GNU CC.
#CC= /usr/pub/bin/gcc -fsigned-char $(OPT) $(GENOPT)
-CC= gcc -W -fsigned-char $(OPT) $(GENOPT)
+CC+= -W -fsigned-char $(OPT) $(GENOPT)
#CC= cc $(OPT) $(GENOPT)
# Miscellaneous CFLAGS. Uncomment the one you need and comment the other
@@ -96,7 +96,8 @@
#CFLAGS= -O2 -funroll-loops -traditional-cpp -DNO_STRING_INCLUDE -DNOFIONREAD # gnu cc 2.00 (hawk)
#CFLAGS= -O2 -funroll-loops -DSEVENBIT # djgpp
#CFLAGS= -g -funroll-loops # gnu cc 2.00 on SunOS with debug
-CFLAGS= -O2 -funroll-loops # gnu cc 2.00 on SunOS
+#CFLAGS= -O2 -funroll-loops # gnu cc 2.00 on SunOS
+CFLAGS+=-fno-strength-reduce
# flags for DJGPP package
#COFF2EXE= coff2exe $(GNUSHOGI)
@@ -454,3 +455,4 @@
-rm -f $(DISTDIR)/gnushogi-$(VERS)/src/gnushogi.bbk
-find $(DISTDIR)/gnushogi-$(VERS) \( -name '*.o' -o -name '*~' -o -name 'CL*' -o -name 'PATCH*' -o -name '#*#' -o -name '%*%' -o -name '*orig' -o -name 'CL*' -o -name '*prt' -o -name '*bak' -o -name '*BAK' \) -exec rm -f {} \;
+DISTDIR=/net/freefall/a/obrien/ports/games/gnushogi/work