fa8a699877
Update to 2.0.r1 also includes: - Rewrite of port Makefile, options closer aligned in order to bsd.port.mk - Added dependency of libiconv (library required by CGI's, currently installed via nagios-plugins port) - Added support for embedded Perl interpreter (requires Perl 5.8+), caching automatically assumed if enabled, off by default - Added support for use of nanosleep() in event timings, off by default - Added ability to override default view at http://webserver/nagios/ URL, suggested values listed in Makefile (validity after future Nagios releases not guaranteed) - Default install location for web component moved to www/nagios, overridable using existing NAGIOSWWWDIR tunable - Corrected minor build issues by tweaking use of CFLAGS - Moved pkg-install, pkg-deinstall and pkg-message into SUB_FILES - Added configuration file tunable (nagios_configfile) for /etc/rc.conf - Configuration tests now show error on failure instead of command to run - Host status (status.sav) now saved across application starts and restarts - Added patch to correct PERL_SYS_INIT3 call in base/utils.c, patch supplied and tested by Karl Friesen <krf@splip.com>, thanks! - Added Apache configuration suggestion in pkg-message for new installs Files changed: - ports/net-mgmt/nagios/Makefile - ports/net-mgmt/nagios/distinfo - ports/net-mgmt/nagios/files/patch-Makefile.in - ports/net-mgmt/nagios/pkg-plist Files created: - ports/net-mgmt/nagios/files/nagios.sh.in - ports/net-mgmt/nagios/files/patch-base-utils.c - ports/net-mgmt/nagios/files/patch-contrib-Makefile.in - ports/net-mgmt/nagios/files/pkg-deinstall.in - ports/net-mgmt/nagios/files/pkg-install.in - ports/net-mgmt/nagios/files/pkg-message.in Files to be removed: - ports/net-mgmt/nagios/files/DEINSTALL.tmpl - ports/net-mgmt/nagios/files/INSTALL.tmpl - ports/net-mgmt/nagios/files/MESSAGE.tmpl - ports/net-mgmt/nagios/files/nagios.sh.tmpl PR: ports/91499 Submitted by: Jarrod Sayers <jarrod@netleader.com.au>
17 lines
877 B
Text
17 lines
877 B
Text
--- contrib/Makefile.in.orig Tue Nov 15 12:19:36 2005
|
|
+++ contrib/Makefile.in Wed Dec 28 17:49:25 2005
|
|
@@ -46,10 +46,10 @@
|
|
devclean: distclean
|
|
|
|
install:
|
|
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CGIDIR)
|
|
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
|
|
- for f in $(CGIS); do $(INSTALL) -m 775 $(INSTALL_OPTS) $$f $(DESTDIR)$(CGIDIR); done
|
|
- for f in $(UTILS); do $(INSTALL) -m 775 $(INSTALL_OPTS) $$f $(DESTDIR)$(BINDIR); done
|
|
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(CGIDIR)
|
|
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
|
|
+ for f in $(CGIS); do $(INSTALL) -m 755 $(INSTALL_OPTS) $$f $(DESTDIR)$(CGIDIR); done
|
|
+ for f in $(UTILS); do $(INSTALL) -m 755 $(INSTALL_OPTS) $$f $(DESTDIR)$(BINDIR); done
|
|
|
|
##############################################################################
|
|
# rules and dependencies for actual target programs
|