freebsd-ports/security/isakmpd/files/patch-sa.c
Alexander Leidinger 7aba119cf1 - Fix the "duplicate script for target <...> ignored" warnings on -current
caused by ${WRKSRC}/Makefile.
- Fix the "extra tokens at end of #else directive" warnings in
  ${WRKSRC}/sysdep/freebsd/sysdep-os.h on -current.
- Fix some format strings in ${WRKSRC}/conf.c and ${WRKSRC}/sa.c for 64 bit
  systems (obtained from NetBSD).
- Move the delta patching ${WRKSRC}/Makefile from patch-ab (priviously
  patching ${WRKSRC}/samples/Makefile and ${WRKSRC}/Makefile) to patch-aa
  (patching ${WRKSRC}/Makefile).
- Build and install certpatch(8), a quite usefull tool to add subjectAltName
  identities to X.509 certificates.

Submitted by:	Marius Strobl <marius@alchemy.franken.de>
2003-09-10 08:22:59 +00:00

25 lines
1,007 B
C

--- sa.c.orig Wed Nov 13 04:31:38 2002
+++ sa.c Sat Feb 8 12:04:21 2003
@@ -440,6 +440,6 @@
LOG_DBG ((cls, level, "%s: msgid %08x refcnt %d", header,
decode_32 (sa->message_id), sa->refcnt));
- LOG_DBG ((cls, level, "%s: life secs %llu kb %llu", header, sa->seconds,
- sa->kilobytes));
+ LOG_DBG ((cls, level, "%s: life secs %llu kb %llu", header, (long long unsigned) sa->seconds,
+ (long long unsigned) sa->kilobytes));
for (proto = TAILQ_FIRST (&sa->protos); proto;
proto = TAILQ_NEXT (proto, link))
@@ -1040,5 +1040,5 @@
LOG_DBG ((LOG_TIMER, 95,
"sa_setup_expirations: SA %p soft timeout in %llu seconds",
- sa, seconds));
+ sa, (long long unsigned) seconds));
expiration.tv_sec += seconds;
sa->soft_death
@@ -1058,5 +1058,5 @@
LOG_DBG ((LOG_TIMER, 95,
"sa_setup_expirations: SA %p hard timeout in %llu seconds",
- sa, sa->seconds));
+ sa, (long long unsigned) sa->seconds));
expiration.tv_sec += sa->seconds;
sa->death