freebsd-ports/lang/php4/files/patch-pear::scripts::pearcmd.php
Alex Dupre 730fa70418 - Fix pear pkg-plist
- Increase pear memory limit (requested by amd64)
- Revert apache2handler to the latest working version found in
  PHP 4.4.0, since PHP developers seem not interested in
  fixing the bug with apache2 and mod_rewrite
2005-11-16 08:24:47 +00:00

21 lines
626 B
PHP

--- pear/scripts/pearcmd.php.orig Mon Mar 28 18:57:01 2005
+++ pear/scripts/pearcmd.php Tue Nov 15 23:25:55 2005
@@ -1,3 +1,4 @@
+#!%%PREFIX%%/bin/php -nq
<?php
//
// +----------------------------------------------------------------------+
@@ -24,9 +25,10 @@
/**
* @nodep Gtk
*/
-if ('@include_path@' != '@'.'include_path'.'@') {
- ini_set('include_path', '@include_path@');
-}
+dl('pcre.so');
+dl('xml.so');
+ini_set('include_path', '%%PREFIX%%/share/pear:%%PREFIX%%/share/pear/bootstrap');
+ini_set('memory_limit', '16M');
ini_set('allow_url_fopen', true);
if (!ini_get('safe_mode')) {
@set_time_limit(0);