5d238a2c8d
Cdrdao changes: o Man page cleanup (Andrew Suffield) GCDMaster changes: o Fixed GCC 4.1 compilation issues o Fixed hang when inserting WAV file - Ensure that the libraries built by the port are linked in and not already installed ones. For example in case of libcdda_paranoia installed by audio/cdparanoia can't be used to build cddao. Such problems only happen when using non-standard compiler and/or linker flags are used but it doesn't hurt to add some anti-footshooting measurements to the port. [1] PR: 115616 [1] Approved by: netchild
13 lines
568 B
Text
13 lines
568 B
Text
--- dao/Makefile.in.orig 2006-09-20 10:51:30.000000000 +0000
|
|
+++ dao/Makefile.in 2007-08-31 22:31:51.000000000 +0000
|
|
@@ -315,8 +315,8 @@
|
|
libdao_a_DEPENDENCIES = \
|
|
@scsilib_objs@
|
|
|
|
-cdrdao_LDADD = -L. -ldao -L$(top_builddir)/paranoia -lcdda_paranoia \
|
|
- -L$(top_builddir)/trackdb -ltrackdb @thread_libs@ \
|
|
+cdrdao_LDADD = ./libdao.a $(top_builddir)/paranoia/libcdda_paranoia.a \
|
|
+ $(top_builddir)/trackdb/libtrackdb.a @thread_libs@ \
|
|
@scsilib_libs@ $(am__append_1) $(am__append_2) @AO_LIBS@
|
|
cdrdao_DEPENDENCIES = \
|
|
$(top_builddir)/paranoia/libcdda_paranoia.a \
|