A C++ library that provides an API to the COLLADA Document Object Model The COLLADA Document Object Model (DOM) is an application programming interface (API) that provides a C++ object representation of a COLLADA XML instance document. This project is a library for loading and saving COLLADA documents that can contain 2D, 3D, physics and other types of content. It allows developers to create applications that can exchange COLLADA documents with commercial content creation tools such as Maya, Max or Softimage. This project is a very lightweight version of the Sourceforce Collada Repository. It maintains only the base collada parser with minimal dependencies. WWW: https://github.com/rdiankov/collada-dom PR: 240635 Submitted by: Trenton Schulz <trueos@norwegianrockcat.com>
20 lines
715 B
Text
20 lines
715 B
Text
--- CMakeLists.txt.orig 2019-05-09 19:44:01 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -2,6 +2,8 @@ cmake_minimum_required (VERSION 2.6.0)
|
|
project (collada-dom)
|
|
set( CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS TRUE )
|
|
|
|
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
|
+
|
|
# Define here the needed parameters
|
|
set (COLLADA_DOM_VERSION_MAJOR 2)
|
|
set (COLLADA_DOM_VERSION_MINOR 5)
|
|
@@ -138,7 +140,7 @@ if( APPLE OR ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
|
|
add_definitions("-Dftello64=ftello")
|
|
endif()
|
|
|
|
-set(COLLADA_DOM_INCLUDE_INSTALL_DIR "include/collada-dom${COLLADA_DOM_SOVERSION}")
|
|
+set(COLLADA_DOM_INCLUDE_INSTALL_DIR "include/collada-dom")
|
|
|
|
set(COLLADA_DOM_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/dom/include)
|
|
set(COLLADA_DOM_LINK_DIRS "")
|