- Also pass --defaults-extra-file to mysql_install_db [1] Submitted by: Daniel Ylitalo <daniel@203core.se>
41 lines
1.3 KiB
Text
41 lines
1.3 KiB
Text
--- libmysql/CMakeLists.txt.orig 2014-03-15 18:08:38.000000000 +0100
|
|
+++ libmysql/CMakeLists.txt 2014-03-22 19:48:26.793800547 +0100
|
|
@@ -180,7 +180,7 @@
|
|
ENDIF()
|
|
|
|
# Merge several convenience libraries into one big perconaserverclient
|
|
-MERGE_LIBRARIES(perconaserverclient STATIC ${LIBS} COMPONENT Development)
|
|
+MERGE_LIBRARIES(perconaserverclient STATIC ${LIBS} COMPONENT Development NOINSTALL)
|
|
|
|
# Visual Studio users need debug static library for debug projects
|
|
INSTALL_DEBUG_SYMBOLS(clientlib)
|
|
@@ -195,6 +195,7 @@
|
|
SET(${out_name} ${name})
|
|
ENDMACRO()
|
|
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
MACRO(GET_VERSIONED_LIBNAME LIBNAME EXTENSION VERSION OUTNAME)
|
|
SET(DOT_VERSION ".${VERSION}")
|
|
@@ -215,13 +216,15 @@
|
|
${lib_name} ${CMAKE_STATIC_LIBRARY_PREFIX}perconaserverclient_r.a
|
|
${INSTALL_LIBDIR} Development)
|
|
ENDIF()
|
|
+ENDIF()
|
|
|
|
IF(NOT DISABLE_SHARED)
|
|
# Merge several convenience libraries into one big perconaserverclient
|
|
# and link them together into shared library.
|
|
MERGE_LIBRARIES(libmysql SHARED ${LIBS}
|
|
EXPORTS ${CLIENT_API_FUNCTIONS}
|
|
- COMPONENT SharedLibraries)
|
|
+ COMPONENT SharedLibraries NOINSTALL)
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
@@ -281,3 +284,4 @@
|
|
ENDFOREACH()
|
|
ENDIF()
|
|
ENDIF()
|
|
+ENDIF()
|