The transition from gcc-aux to gcc5-aux in the Ada framework has been blocked by the inability to build gtkada3 and, once resolved, GPS (due to tight locking with compiler). A few days ago, Adacore made their annual release of their main libre products, include GPS. However, some products were tightly coupled with the recent compilers, so in order to upgrade, the compiler had to be switched and dependencies require many ports to be upgraded at once: * lang/asis * devel/gnatcoll * devel/gps * x11-toolkits/gtkada3 * www/aws * www/aws-demos While the version upgrades were modest in most cases (gps, gtkada3), the amount of work put into each port was significant. There are too many improvements to mention here. A few include the removal of dynamic package lists and incorporating gnatcoll into gps to avoid building it twice. A private "exp-run" was done all on all 50+ Ada ports to ensure they still build. Also, a new argument was added to Uses/ada.mk, "run", that pulls in the GNAT compiler as a run depends. This was necessary for GPS that will not launch correctly without the compiler in place.
42 lines
934 B
Text
42 lines
934 B
Text
--- docs/Makefile.in.orig 2014-11-13 18:15:57 UTC
|
|
+++ docs/Makefile.in
|
|
@@ -1,10 +1,9 @@
|
|
prefix = @prefix@
|
|
-docdir = $(prefix)/share/doc/gps
|
|
-sharedir = $(prefix)/share/gps
|
|
+docdir = $(DESTDIR)$(prefix)/share/doc/gps
|
|
+sharedir = $(DESTDIR)$(prefix)/share/gps
|
|
|
|
MKDIR = mkdir -p
|
|
-INSTALL = @INSTALL@
|
|
-INSTALL_DATA = @INSTALL_DATA@
|
|
+INSTALL_DATA = $(BSD_INSTALL_DATA)
|
|
CONVERT = convert
|
|
CP = cp -p
|
|
|
|
@@ -12,20 +11,20 @@ all: ug tutorial gps_pg relnotes gnatdoc
|
|
static:
|
|
|
|
gps_pg:
|
|
- make -C programmers_guide html
|
|
+ $(MAKE) -C programmers_guide html
|
|
|
|
relnotes:
|
|
- make -C release_notes singlehtml
|
|
+ $(MAKE) -C release_notes singlehtml
|
|
|
|
ug:
|
|
- make -C users_guide html latexpdf
|
|
+ $(MAKE) -C users_guide html
|
|
|
|
gnatdoc:
|
|
- make -C ../gnatdoc/docs/users_guide html latexpdf
|
|
+ $(MAKE) -C ../gnatdoc/docs/users_guide html
|
|
|
|
.PHONY: tutorial
|
|
tutorial:
|
|
- make -C tutorial html
|
|
+ $(MAKE) -C tutorial html
|
|
|
|
install:
|
|
$(MKDIR) $(docdir)
|