freebsd-ports/devel/gps/files/patch-shared.gpr
John Marino fc445b2e3f Ada Framework: Switch to gcc5-aux, upgrade 6 packages at once
The transition from gcc-aux to gcc5-aux in the Ada framework has been
blocked by the inability to build gtkada3 and, once resolved, GPS (due
to tight locking with compiler).

A few days ago, Adacore made their annual release of their main libre
products, include GPS.  However, some products were tightly coupled with
the recent compilers, so in order to upgrade, the compiler had to be
switched and dependencies require many ports to be upgraded at once:

  * lang/asis
  * devel/gnatcoll
  * devel/gps
  * x11-toolkits/gtkada3
  * www/aws
  * www/aws-demos

While the version upgrades were modest in most cases (gps, gtkada3), the
amount of work put into each port was significant.  There are too many
improvements to mention here.  A few include the removal of dynamic
package lists and incorporating gnatcoll into gps to avoid building it
twice.  A private "exp-run" was done all on all 50+ Ada ports to ensure
they still build.

Also, a new argument was added to Uses/ada.mk, "run", that pulls in the
GNAT compiler as a run depends.  This was necessary for GPS that will
not launch correctly without the compiler in place.
2015-06-23 22:20:35 +00:00

47 lines
1.4 KiB
Text

--- shared.gpr.orig 2015-01-19 12:21:19 UTC
+++ shared.gpr
@@ -1,4 +1,6 @@
-with "gnatlib/gnatcoll_shared";
+with "gnatcoll_iconv";
+with "gnatcoll_gtk";
+with "gnatcoll_python";
project Shared is
@@ -9,8 +11,7 @@ project Shared is
Build : Build_Type := External ("Build", "Production");
for Source_Dirs use ();
- for Object_Dir use Gnatcoll_Shared'Object_Dir;
- for Library_Dir use Gnatcoll_Shared'Library_Dir;
+ for Object_Dir use "obj";
type VCS_Type is ("Subversion", "Git", "Auto");
VCS_Kind : VCS_Type := External ("PRJ_VCS", "Subversion");
@@ -34,7 +35,7 @@ project Shared is
"-gnatwaCJe", "-gnat2012", "-gnateE");
for Default_Switches ("C") use
- ("-g", "-O1", "-fdump-xref") & GnatColl_Shared.Gtk_Include;
+ ("-g", "-O1");
when "Production" =>
for Default_Switches ("Ada") use
@@ -42,7 +43,7 @@ project Shared is
"-gnatT3", -- Temporary, L403-023.
"-gnatws", "-gnat12");
for Default_Switches ("C") use
- ("-g", "-O2") & GnatColl_Shared.Gtk_Include;
+ ("-g", "-O2");
end case;
end Compiler;
@@ -51,7 +52,7 @@ project Shared is
end Binder;
package Linker is
- for Default_Switches ("Ada") use Gnatcoll_Shared.System_Linker_Flags;
+ for Default_Switches ("Ada") use ();
end Linker;
end Shared;