- regenerated configure to use gcc42 gfortran42 with py-numpy - fixed botch with missing gmtime_r_ (already fixed upstream) - fixed wsjt to use py-numpy instead of deprecated py-numeric - fixed to use portaudio v19 already in ports - fixed to run on amd due to above - maho wants WANT_FORTRAN knob in gfortran ports Pointy hat to: pav,maho Approved by: ehaupt (mentor)
142 lines
4.4 KiB
Text
142 lines
4.4 KiB
Text
--- configure.orig Sat Oct 21 14:19:10 2006
|
|
+++ configure Tue Feb 20 08:26:44 2007
|
|
@@ -1,8 +1,8 @@
|
|
#! /bin/sh
|
|
# Guess values for system-dependent variables and create Makefiles.
|
|
-# Generated by GNU Autoconf 2.59 for wsjt 5.9.2.
|
|
+# Generated by GNU Autoconf 2.59 for wsjt 5.9.5.
|
|
#
|
|
-# $Id: configure.ac 259 2006-08-10 22:22:33Z va3db $
|
|
+# $Id: configure.ac 270 2006-09-04 19:18:34Z k1jt $
|
|
#
|
|
# Copyright (C) 2003 Free Software Foundation, Inc.
|
|
# This configure script is free software; the Free Software Foundation
|
|
@@ -253,7 +253,7 @@
|
|
#
|
|
# Initializations.
|
|
#
|
|
-ac_default_prefix=/usr/local
|
|
+ac_default_prefix=%%PREFIX%%
|
|
ac_config_libobj_dir=.
|
|
cross_compiling=no
|
|
subdirs=
|
|
@@ -269,11 +269,11 @@
|
|
# Identity of this package.
|
|
PACKAGE_NAME='wsjt'
|
|
PACKAGE_TARNAME='wsjt'
|
|
-PACKAGE_VERSION='5.9.2'
|
|
-PACKAGE_STRING='wsjt 5.9.2'
|
|
+PACKAGE_VERSION='5.9.5'
|
|
+PACKAGE_STRING='wsjt 5.9.5'
|
|
PACKAGE_BUGREPORT=''
|
|
|
|
-ac_default_prefix=/usr/local/
|
|
+ac_default_prefix=%%PREFIX%%/
|
|
# Factoring default headers for most tests.
|
|
ac_includes_default="\
|
|
#include <stdio.h>
|
|
@@ -788,7 +788,7 @@
|
|
# Omit some internal or obsolete options to make the list less imposing.
|
|
# This message is too long to be a string in the A/UX 3.1 sh.
|
|
cat <<_ACEOF
|
|
-\`configure' configures wsjt 5.9.2 to adapt to many kinds of systems.
|
|
+\`configure' configures wsjt 5.9.5 to adapt to many kinds of systems.
|
|
|
|
Usage: $0 [OPTION]... [VAR=VALUE]...
|
|
|
|
@@ -845,7 +845,7 @@
|
|
|
|
if test -n "$ac_init_help"; then
|
|
case $ac_init_help in
|
|
- short | recursive ) echo "Configuration of wsjt 5.9.2:";;
|
|
+ short | recursive ) echo "Configuration of wsjt 5.9.5:";;
|
|
esac
|
|
cat <<\_ACEOF
|
|
|
|
@@ -969,14 +969,14 @@
|
|
test -n "$ac_init_help" && exit 0
|
|
if $ac_init_version; then
|
|
cat <<\_ACEOF
|
|
-wsjt configure 5.9.2
|
|
+wsjt configure 5.9.5
|
|
generated by GNU Autoconf 2.59
|
|
|
|
Copyright (C) 2003 Free Software Foundation, Inc.
|
|
This configure script is free software; the Free Software Foundation
|
|
gives unlimited permission to copy, distribute and modify it.
|
|
|
|
-$Id: configure.ac 259 2006-08-10 22:22:33Z va3db $
|
|
+$Id: configure.ac 270 2006-09-04 19:18:34Z k1jt $
|
|
_ACEOF
|
|
exit 0
|
|
fi
|
|
@@ -985,7 +985,7 @@
|
|
This file contains any messages produced by compilers while
|
|
running configure, to aid debugging if configure makes a mistake.
|
|
|
|
-It was created by wsjt $as_me 5.9.2, which was
|
|
+It was created by wsjt $as_me 5.9.5, which was
|
|
generated by GNU Autoconf 2.59. Invocation command line was
|
|
|
|
$ $0 $@
|
|
@@ -2500,8 +2500,8 @@
|
|
|
|
CFLAGS="$OLD_CFLAGS"
|
|
|
|
-CPPFLAGS="-Iportaudio-v19/include -I/usr/local/include -I/usr/include/alsa -I/usr/local/include/alsa ${CPPFLAGS}"
|
|
-LDFLAGS="-L/usr/local/lib ${LDFLAGS}"
|
|
+CPPFLAGS="-I%%LOCALBASE%%/include/portaudio2 -I%%LOCALBASE%%/include -I/usr/include/alsa -I%%LOCALBASE%%/include/alsa ${CPPFLAGS}"
|
|
+LDFLAGS="-L%%LOCALBASE%%/lib/portaudio2 -L%%LOCALBASE%%/lib ${LDFLAGS}"
|
|
LIBS=" -lpthread ${LIBS}"
|
|
|
|
echo "$as_me:$LINENO: checking uname -s for Cygwin, Solaris or HPUX" >&5
|
|
@@ -3657,8 +3657,8 @@
|
|
echo "${ECHO_T}no" >&6
|
|
fi
|
|
|
|
-# Extract the first word of "gfortran41", so it can be a program name with args.
|
|
-set dummy gfortran41; ac_word=$2
|
|
+# Extract the first word of "gfortran42", so it can be a program name with args.
|
|
+set dummy gfortran42; ac_word=$2
|
|
echo "$as_me:$LINENO: checking for $ac_word" >&5
|
|
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
|
|
if test "${ac_cv_path_GFORTRAN+set}" = set; then
|
|
@@ -4615,7 +4615,7 @@
|
|
fi
|
|
|
|
|
|
-if test -e "portaudio-v19/include/portaudio.h" ; then
|
|
+if test -e "%%LOCALBASE%%/include/portaudio2/portaudio.h" ; then
|
|
echo "Checking for portaudio...yes"
|
|
HAS_PORTAUDIO_H=1
|
|
else
|
|
@@ -6882,9 +6882,9 @@
|
|
|
|
AUDIO="a2d.f90 jtaudio.c resample.c start_portaudio.c"
|
|
|
|
- NEEDPORTAUDIO="portaudio-v19/lib/.libs/libportaudio.a"
|
|
+ NEEDPORTAUDIO=""
|
|
|
|
- LIBS="${LIBS} ${RTLIBS} -lsamplerate ./portaudio-v19/lib/.libs/libportaudio.a"
|
|
+ LIBS="${LIBS} ${RTLIBS} -lsamplerate -lportaudio"
|
|
LIBS="${LIBS} ${ASOUNDLIBS}"
|
|
else
|
|
NEEDPORTAUDIO=""
|
|
@@ -7364,7 +7364,7 @@
|
|
} >&5
|
|
cat >&5 <<_CSEOF
|
|
|
|
-This file was extended by wsjt $as_me 5.9.2, which was
|
|
+This file was extended by wsjt $as_me 5.9.5, which was
|
|
generated by GNU Autoconf 2.59. Invocation command line was
|
|
|
|
CONFIG_FILES = $CONFIG_FILES
|
|
@@ -7419,7 +7419,7 @@
|
|
|
|
cat >>$CONFIG_STATUS <<_ACEOF
|
|
ac_cs_version="\\
|
|
-wsjt config.status 5.9.2
|
|
+wsjt config.status 5.9.5
|
|
configured by $0, generated by GNU Autoconf 2.59,
|
|
with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
|
|
|