freebsd-ports/devel/py-streamparse/files/patch-setup.py
Vinícius Zavam e959ca709b
devel/py-streamparse: update 3.16.0 to 4.0.0
- github.com/Parsely/streamparse/releases/tag/v4.0.0

Reported by:	ygy@
PR:		257428
2021-10-04 10:04:00 +00:00

19 lines
537 B
Python

--- setup.py.orig 2021-10-04 08:45:30 UTC
+++ setup.py
@@ -14,6 +14,7 @@ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either e
See the License for the specific language governing permissions and
limitations under the License.
"""
+import codecs
import re
from setuptools import setup, find_packages
@@ -28,7 +29,7 @@ def get_version():
def readme():
""" Returns README.rst contents as str """
- with open("README.rst") as f:
+ with codecs.open('README.rst', 'r', encoding='utf8') as f:
return f.read()