freebsd-ports/math/armadillo/files/patch-CMakeLists.txt
Danilo Egea Gondolfo 001b628a5e - Update to 7.300.1
- Re-add the config.hpp patch

PR:		211559
Submitted by:	pi
2016-08-03 19:37:59 +00:00

21 lines
1.2 KiB
Text

--- CMakeLists.txt.orig 2016-06-16 16:16:01 UTC
+++ CMakeLists.txt
@@ -368,12 +368,12 @@ if(NOT INSTALL_LIB_DIR)
message(STATUS "*** Detected 64 bit system")
# use "lib64" only on systems that have it (eg. Fedora, Red Hat).
# if installing in /usr/local/, the use of lib64 might be unreliable on systems which have /usr/local/lib64 but don't use it
- if(IS_DIRECTORY "${CMAKE_INSTALL_PREFIX}/lib64")
- unset(INSTALL_LIB_DIR)
- set(INSTALL_LIB_DIR "lib64")
- message(STATUS "*** ${CMAKE_INSTALL_PREFIX}/lib64/ exists, so destination directory for the run-time library changed to ${CMAKE_INSTALL_PREFIX}/lib64/")
- message(STATUS "*** Your system and/or compiler must search ${CMAKE_INSTALL_PREFIX}/lib64/ during linking")
- endif()
+# if(IS_DIRECTORY "${CMAKE_INSTALL_PREFIX}/lib64")
+# unset(INSTALL_LIB_DIR)
+# set(INSTALL_LIB_DIR "lib64")
+# message(STATUS "*** ${CMAKE_INSTALL_PREFIX}/lib64/ exists, so destination directory for the run-time library changed to ${CMAKE_INSTALL_PREFIX}/lib64/")
+# message(STATUS "*** Your system and/or compiler must search ${CMAKE_INSTALL_PREFIX}/lib64/ during linking")
+# endif()
endif()
endif()
endif()