5afd89e04e
- remove manpages from files, they are now included w/dist - sort pkg-plist PR: 31062 Submitted by: Dmitry Morozovsky <marck@rinet.ru>
55 lines
1.1 KiB
Text
55 lines
1.1 KiB
Text
--- Makefile.orig Thu Oct 4 22:18:29 2001
|
|
+++ Makefile Fri Oct 5 21:00:34 2001
|
|
@@ -1,23 +1,14 @@
|
|
-PLATFORM = LINUX
|
|
+#PLATFORM = LINUX
|
|
#PLATFORM = SOLARIS
|
|
-#PLATFORM = FreeBSD
|
|
-CC = gcc
|
|
+PLATFORM = FreeBSD
|
|
+#CC = gcc
|
|
#DEBUG = yes
|
|
#CFLAGS = -g
|
|
#CFLAGS = -O6
|
|
-STRIP = strip
|
|
+#STRIP = strip
|
|
#STRIP = gstrip
|
|
LIBS = -lm
|
|
-CFLAGS = -I/usr/lib/glib/include
|
|
-
|
|
-ifeq ($(PLATFORM),SOLARIS)
|
|
- LIBS += -lsocket -lnsl -lresolv
|
|
-endif
|
|
-
|
|
-ifeq ($(DEBUG),yes)
|
|
- CFLAGS += -g
|
|
-endif
|
|
-
|
|
+CFLAGS+= -DASNCDIR=\"${PREFIX}/share/ehnt\"
|
|
|
|
all: ehntserv ehnt asnc.txt
|
|
@echo
|
|
@@ -40,11 +31,6 @@
|
|
|
|
ehnt : ehnt_client.o ehnt_lookup.o ehnt_display.o ehnt_processflow.o ehnt_main.o
|
|
$(CC) -o ehnt ehnt_client.o ehnt_lookup.o ehnt_display.o ehnt_processflow.o ehnt_main.o $(LIBS) $(CFLAGS)
|
|
-ifeq ($(DEBUG),yes)
|
|
- @echo Debug mode - ehnt not stripped
|
|
-else
|
|
- $(STRIP) ehnt
|
|
-endif
|
|
|
|
|
|
ehntserv.o : ehntserv.c ehnt.h netflowv5.h config.h
|
|
@@ -52,11 +38,6 @@
|
|
|
|
ehntserv : ehntserv.o
|
|
$(CC) $(CFLAGS) -o ehntserv ehntserv.o $(LIBS) $(CFLAGS)
|
|
-ifeq ($(DEBUG),yes)
|
|
- @echo Debug mode - ehnt not stripped
|
|
-else
|
|
- $(STRIP) ehntserv
|
|
-endif
|
|
|
|
asnc.txt :
|
|
perl ./ProcessASN.pl
|