freebsd-ports/databases/postgresql90-server/files/patch-doc-Makefile
Palle Girgensohn 00c3beec39 Welcome PostgreSQL 8.4
After many years of development, PostgreSQL has become feature-complete in many areas.
This release shows a targeted approach to adding features (e.g., authentication,
monitoring, space reuse), and adds capabilities defined in the later SQL standards.
The major areas of enhancement are:

Windowing Functions
Common Table Expressions and Recursive Queries
Default and variadic parameters for functions
Parallel Restore
Column Permissions
Per-database locale settings
Improved hash indexes
Improved join performance for EXISTS and NOT EXISTS queries
Easier-to-use Warm Standby
Automatic sizing of the Free Space Map
Visibility Map (greatly reduces vacuum overhead for slowly-changing tables)
Version-aware psql (backslash commands work against older servers)
Support SSL certificates for user authentication
Per-function runtime statistics
Easy editing of functions in psql
New contrib modules: pg_stat_statements, auto_explain, citext, btree_gin

URL: http://www.postgresql.org/docs/8.4/interactive/release-8-4.html
2009-07-07 22:30:06 +00:00

16 lines
479 B
Text

--- doc/Makefile.orig 2009-05-15 15:58:05.000000000 +0200
+++ doc/Makefile 2009-05-15 15:58:18.000000000 +0200
@@ -25,9 +25,10 @@
.NOTPARALLEL:
-ifneq ($(wildcard $(srcdir)/postgres.tar.gz),)
-found_html = yes
-endif
+# FreeBSD has a separate port for installing the documentation
+#ifneq ($(wildcard $(srcdir)/postgres.tar.gz),)
+#found_html = yes
+#endif
ifneq ($(wildcard $(srcdir)/man.tar.gz),)
# SCO OpenServer's man system is sufficiently different to not bother.