freebsd-ports/lang/python-devel/files/patch-setup.py
Hye-Shik Chang 03cd3fd2e0 - Update to 2.4a2
- Add IPV6 option [1]

PR:		69950 [1]
Submitted by:	Marcus Grando <marcus@corp.grupos.com.br> [1]
2004-08-07 06:36:57 +00:00

21 lines
716 B
Python

--- setup.py.orig Sun Jun 27 07:29:42 2004
+++ setup.py Thu Jul 8 23:55:04 2004
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1160,8 +1160,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install
- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
- 'Lib/smtpd.py']
+ scripts = []
)
# --install-platlib