fbb904c849
Despite the name, kf5-oxygen-icons5 does not depend on Qt5 and just contains the Oxygen icon set without any architecture-dependent files. As such, we can make all ports depend on it and remove kde4-icons-oxygen altogether and avoid having two conflicting ports for KDE4 and KF5. x11-themes/kf5-oxygen-icons5 was adjusted to have its dependencies reduced even further: - The dependencies on qt5-core and qt5-testlib were removed, as they were only needed to build tests. - We're also passing some CMake arguments to avoid looking for qt5-core altogether. With the changes above, the only port kf5-oxygen-icons5 depends on at runtime is devel/kf5-extra-cmake-modules, which itself does not depend on anything else. Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D10237
12 lines
396 B
Text
12 lines
396 B
Text
Do not build tests by default to avoid having to depend on Qt5.
|
|
--- CMakeLists.txt.orig 2017-04-02 18:01:03 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -20,8 +20,6 @@ set(REQUIRED_QT_VERSION 5.6.0)
|
|
|
|
set( oxygen_icon_dirs 8x8 16x16 22x22 32x32 48x48 64x64 128x128 256x256 )
|
|
|
|
-add_subdirectory(autotests)
|
|
-
|
|
########### install files ###############
|
|
|
|
set(OXYGEN_INSTALL_DIR ${KDE_INSTALL_ICONDIR}/oxygen/base)
|