36b8c14ea2
PR: ports/135272 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Approved by: maintainer timeout (olgeni; 19 days)
51 lines
1.5 KiB
Text
51 lines
1.5 KiB
Text
--- c_src/Makefile.orig 2009-05-20 22:34:48.000000000 +0400
|
|
+++ c_src/Makefile 2009-06-02 06:19:34.000000000 +0400
|
|
@@ -11,7 +11,7 @@
|
|
include ../win32_conf/mingw_vars.mk
|
|
else
|
|
|
|
- OGLDIR = /usr
|
|
+ OGLDIR = ${LOCALBASE}
|
|
|
|
# Uncomment these if your opengl header is located in another directory than
|
|
# the usual $(OGLDIR)/include/GL/gl.h
|
|
@@ -21,8 +21,8 @@
|
|
GL_LIBS = -L$(OGLDIR)/lib -lGL -lGLU
|
|
GL_INCS = -I$(OGLDIR)/include/$(GL_INCLUDE_DIR)
|
|
|
|
- SDL_LIBS = $(shell sdl-config --libs)
|
|
- SDL_INCS = $(shell sdl-config --cflags)
|
|
+ SDL_LIBS = $(shell $(SDL_CONFIG) --libs)
|
|
+ SDL_INCS = $(shell $(SDL_CONFIG) --cflags)
|
|
|
|
ifeq ($(ENABLE_SDL_TTF), yes)
|
|
SDL_TTF_LIBS = -lSDL_ttf
|
|
@@ -43,10 +43,8 @@
|
|
INCS = $(GL_INCS) $(SDL_INCS) $(SDL_TTF_INCS) \
|
|
$(SDL_IMAGE_INCS) $(ERL_INCS)
|
|
|
|
- CFLAGS = -g -O2 -funroll-loops -Wall -ffast-math -fpic \
|
|
- -fomit-frame-pointer $(USE_GL_INCLUDE_DIR) -DSHM \
|
|
- $(USE_SDL_TTF) $(USE_SDL_IMAGE) \
|
|
- -DPTHREADS $(INCS)
|
|
+ CFLAGS += -O2 -funroll-loops -Wall -ffast-math -fpic -fomit-frame-pointer \
|
|
+ $(USE_GL_INCLUDE_DIR) -DSHM $(USE_SDL_TTF) $(USE_SDL_IMAGE) -DPTHREADS $(INCS)
|
|
|
|
CLINKFLAGS = -fpic -shared
|
|
|
|
@@ -56,13 +54,13 @@
|
|
ERL_DIR := $(shell erl -noshell -eval "io:format([126,115,126,110],[code:root_dir()])" -s erlang halt)
|
|
ERL_INCS = -I$(ERL_DIR)/usr/include
|
|
|
|
- CC = gcc
|
|
+ CC ?= gcc
|
|
|
|
endif
|
|
|
|
TARGETDIR = ../priv
|
|
|
|
-GCC_O = $(CC) -c $(CFLAGS) $<
|
|
+GCC_O = $(CC) -c $(CFLAGS) $(INCS) $(ERLINC) $<
|
|
|
|
# Files
|
|
|