21 lines
685 B
Text
21 lines
685 B
Text
--- samba/Makefile.orig Sun Jun 16 13:32:01 2002
|
|
+++ samba/Makefile Sun Jun 16 13:34:56 2002
|
|
@@ -1,13 +1,13 @@
|
|
#this should default to something and then be set by configure switches
|
|
-prefix=/usr/local/samba
|
|
+prefix=${LOCALBASE}
|
|
exec_prefix=${prefix}
|
|
-LIBDIR = ${exec_prefix}/lib
|
|
+LIBDIR = ${exec_prefix}/etc
|
|
LMHOSTSFILE = $(LIBDIR)/lmhosts
|
|
CODEPAGEDIR = $(LIBDIR)/codepages
|
|
-SMBRUN = $(BINDIR)/smbrun
|
|
+SMBRUN = $(prefix)/bin/smbrun
|
|
DRIVERFILE = $(LIBDIR)/printers.def
|
|
-SMB_PASSWD_FILE = $(PRIVATEDIR)/smbpasswd
|
|
-PASSWD_PROGRAM = /bin/passwd
|
|
+SMB_PASSWD_FILE = $(prefix)/private/smbpasswd
|
|
+PASSWD_PROGRAM = /usr/bin/passwd
|
|
|
|
|
|
LIB_OBJ = lib/charcnv.o lib/charset.o lib/debug.o \
|