freebsd-ports/textproc/chpp/files/patch-avl.h
Alexey Dokuchaev 6c4236362b - Fix the build with modern GCC [1]
- Clean up Makefile, pacify portlint(1)
- Use our standard FOOBARDIR macros in pkg-plist
- Minor pkg-descr nit

Reported by:	pointyhat (logs) [1]
2007-07-02 10:07:53 +00:00

15 lines
499 B
C

--- avl.h.orig Thu Oct 29 02:25:09 1998
+++ avl.h Mon Jul 2 16:47:44 2007
@@ -44,7 +44,11 @@
} avlTree;
#define AVL_LINK(a,N) (((a) == -1) ? (N)->left : (N)->right)
-#define AVL_LINK_SET(s,P,V) ((((s) == -1) ? (P)->left : (P)->right) = (V))
+#define AVL_LINK_SET(s,P,V) \
+ do { \
+ typeof (V) foo = (((s) == -1) ? (P)->left : (P)->right); \
+ foo = (V); \
+ } while (0)
int avlCompare (avlTree*, void*, unsigned int, avlNode*);
int avlBalance (avlNode*, int, avlNode**);