- Fix build with gcc 4.2 - pet portlint PR: 117648 (based on) Submitted by: Pietro Cerutti <gahr@gahr.ch>
29 lines
458 B
Text
29 lines
458 B
Text
--- util/Makefile Wed Mar 22 19:05:32 1995
|
|
+++ util/Makefile Wed Jul 1 18:41:55 1998
|
|
@@ -9,14 +9,15 @@
|
|
|
|
UTIL := util.a
|
|
|
|
-SRCS := $(shell ls *.c)
|
|
+SRCS := error.c misc.c names.c sym.c hash.c
|
|
+
|
|
OBJS := $(SRCS:.c=.o)
|
|
|
|
###
|
|
### Abstract rules
|
|
###
|
|
|
|
-default: $(UTIL)
|
|
+all: $(UTIL)
|
|
|
|
install: default
|
|
|
|
@@ -32,7 +33,7 @@
|
|
|
|
$(UTIL): $(OBJS)
|
|
$(RM) $(UTIL)
|
|
- $(AR) rcs $(UTIL) $(OBJS)
|
|
+ $(AR) -rc $(UTIL) $(OBJS)
|
|
|
|
###
|
|
### Additional dependencies
|