freebsd-ports/net/openntpd/files/patch-Makefile
Christian Weisgerber 2bc38c4ec1 Update to 4.6:
* DNS queries are delegated to a dedicated child process.
* The -v option will log all time adjustments.
2009-11-24 14:55:52 +00:00

20 lines
568 B
Text

$FreeBSD$
--- Makefile.orig 2009-11-23 20:27:18.000000000 +0100
+++ Makefile 2009-11-23 20:29:05.000000000 +0100
@@ -2,7 +2,7 @@
PROG= ntpd
SRCS= ntpd.c buffer.c log.c imsg.c ntp.c ntp_msg.c parse.y config.c \
- server.c client.c sensors.c util.c ntp_dns.c
+ server.c client.c util.c ntp_dns.c adjfreq.c arc4random.c
CFLAGS+= -Wall -I${.CURDIR}
CFLAGS+= -Wstrict-prototypes -Wmissing-prototypes
CFLAGS+= -Wmissing-declarations
@@ -11,4 +11,7 @@ CFLAGS+= -Wsign-compare
YFLAGS=
MAN= ntpd.8 ntpd.conf.5
+DPADD= ${LIBMD}
+LDADD= -lmd
+
.include <bsd.prog.mk>