df98f1dff5
in many of my programs, but which aren't "big enough" to warrant an individual library. Key features of Coyotl include: -- A polymorphic collection of the best psuedorandom number generators, including the Mersenne Twister and Marsaglia's favorites. -- Utilities for floating-point numbers, including additional functions for trigonometry, least common multiple, greatest common denominator, rounding, and other purposes. -- A simple cross-platform command-line parser. -- A framework for generating random rectangular mazes. -- A template for fixed-point math based on different integer sizes and decimal point locations. -- Templatized sorting utilities (designed before Std. C++'s <algorithms>, but still useful) -- Validation tools for "Design by Contract" programming. WWW: http://www.coyotegulch.com/products/libcoyotl/index.html PR: ports/101209 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
12 lines
399 B
Text
12 lines
399 B
Text
diff -urN test.orig/Makefile.in test/Makefile.in
|
|
--- test.orig/Makefile.in Tue Aug 1 18:01:32 2006
|
|
+++ test/Makefile.in Tue Aug 1 18:01:44 2006
|
|
@@ -112,7 +112,7 @@
|
|
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
|
LDFLAGS = @LDFLAGS@
|
|
LIBOBJS = @LIBOBJS@
|
|
-LIBS = -L../libcoyotl -lrt -lpng -lcoyotl
|
|
+LIBS = -L../libcoyotl -lpng -lcoyotl
|
|
LIBTOOL = @LIBTOOL@
|
|
LN_S = @LN_S@
|
|
LTLIBOBJS = @LTLIBOBJS@
|