freebsd-ports/textproc/sgrep/files/patch-Makefile
Muhammad Moinur Rahman 3a946c7f6a textproc/sgrep: Add LICENSE GPLv2
- Add PORTSCOUT to limit version 1
- Fix patches for 'make makepatch'
- Remove pkg-plist for PLIST_FILES
- Take MAINTIAINER
2017-09-21 16:06:20 +00:00

39 lines
938 B
Text

--- Makefile.orig 1996-05-02 11:58:24 UTC
+++ Makefile
@@ -10,11 +10,11 @@
#
# This is where the executable goes
-BINDIR = /usr/local/bin/
+BINDIR = ${PREFIX}/bin
# Where sgrep library files are placed (sgreprc)
-LIBDIR = /usr/local/lib
+LIBDIR = ${PREFIX}/share
# Where the manual page goes
-MANFILE = /usr/local/man/man1/sgrep.1
+MANFILE = ${PREFIX}/man/man1/sgrep.1
# Where the sample rc file goes
RCFILE = $(LIBDIR)/sgreprc
# If you can't install as root you might wan't to use this as rc file
@@ -25,7 +25,7 @@ VERSION = 0.99
CFLAGS = -O -DVERSION=\"$(VERSION)\" -DLIBDIR=\"$(LIBDIR)\"
LDFLAGS =
# if cc fails to you use gcc
-CC = cc
+#CC = cc
CPPFLAGS =
LIBS =
@@ -45,11 +45,7 @@ sgrep: $(OBJECTS)
clean:
-rm -f $(OBJECTS)
-install: sgrep
- cp sgrep $(BINDIR)/sgrep
- chmod 755 $(BINDIR)/sgrep
- cp sgrep.1 $(MANFILE)
- chmod 644 $(MANFILE)
+install:
install.rc: sample.sgreprc
cp sample.sgreprc $(RCFILE)