freebsd-ports/lang/python32/files/patch-Lib_distutils_command_build_ext.py
Marcus von Appen 7360f89ed2 - Remove everything related to USE_PYTHON and bsd.python.mk. This is a
preparatory step to convert bsd.python.mk into a USES file.
- Remove the shared/static build separation, which is the source of many
  problems and even more hacks. Instead build only the shared version, which
  greatly simplifies the build.
- Use NLS_LIBS instead of NLS_LDFLAGS as done for lang/python27 (r357486)
- Remove the FPECTL option to align the build with the clean "template" from
  lang/python34.
- Remove PORTDATA and EXAMPLES. Those will be made available via separate
  ports.
- Add a new DEBUG option to enable debug builds as for lang/python34.
- Add a new TSC option for precise timestamp counter support as for
  lang/python34.
- Add CPE support.
- Reactivate curses/ncurses support.
- Use buildbottest in the regression-test: target.

Phabric:		D448
Reviewed by:	koobs, bapt
With hat:		python@
2014-08-01 16:37:54 +00:00

17 lines
989 B
Python

--- Lib/distutils/command/build_ext.py.orig 2014-07-20 11:51:54.000000000 +0200
+++ Lib/distutils/command/build_ext.py 2014-07-20 11:52:52.000000000 +0200
@@ -236,12 +236,9 @@
# building python standard extensions
self.library_dirs.append('.')
- # for extensions under Linux or Solaris with a shared Python library,
# Python's library directory must be appended to library_dirs
- sysconfig.get_config_var('Py_ENABLE_SHARED')
- if ((sys.platform.startswith('linux') or sys.platform.startswith('gnu')
- or sys.platform.startswith('sunos'))
- and sysconfig.get_config_var('Py_ENABLE_SHARED')):
+ # See Issues: #1600860, #4366
+ if (sysconfig.get_config_var('Py_ENABLE_SHARED')):
if sys.executable.startswith(os.path.join(sys.exec_prefix, "bin")):
# building third party extensions
self.library_dirs.append(sysconfig.get_config_var('LIBDIR'))