- Changes PORTVERSION to DISTVERSION - Sets submitter as MAINTAINER. - Uses USE_GITHUB instead of MASTER_SITES - Sets LICENSE - Sets appropriate dependencies, USES, USE_X - Adds an EXAMPLES option - Adds a pkg-message to explain how the port must be used, as it is not self-evident (The software assumes all files in the same directory instead of distributed into bin/, ${DATADIR} etc so I had to find a work around: the solution is easy for the user). PR: 233772 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch> Reviewed by: chitty_cloud@me.com Relnotes: https://forum.z88.de/viewtopic.php?f=18&t=885
12 lines
510 B
Text
12 lines
510 B
Text
--- make/make_unix_64/z88com.mk.gcc64.orig 2018-12-05 14:30:53 UTC
|
|
+++ make/make_unix_64/z88com.mk.gcc64
|
|
@@ -10,8 +10,7 @@ DIRCOM = $(DIRECA)/src/z88com/common
|
|
DIROUT = $(DIRECA)/bin/unix64
|
|
|
|
CC = gcc
|
|
-CFLAGS = -I$(DIRCOM) -DFR_UNIX -DFR_XDOUB -DFR_XLONG -DFR_LINUX -O2 \
|
|
- `pkg-config --cflags --libs gtk+-2.0`
|
|
+CFLAGS = -I$(DIRCOM) -DFR_UNIX -DFR_XDOUB -DFR_XLONG -DFR_LINUX -O2 `pkg-config --cflags --libs gtk+-2.0`
|
|
|
|
OBJECTSC = z88com.o cb88c.o ale88c.o lan88c.o wlog88c.o rcol88c.o
|
|
|