dae4751ead
<ChangeLog> --[ Redis 3.0.0 RC2 (version 2.9.102) ] Release date: 13 jan 2014 Upgrade urgency: LOW. This is the second release candidate of Redis Cluster. The major changes are back porting of things implemented into the unstable branch while this was still possible (with the new development model adopted only bug fixes will be merged in the future). RC2 also fixes a few Redis Cluster non critical bugs. >> General changes * [FIX] A number of minor bug fixes. * [NEW] Diskless replication backportede. * [NEW] Lua bitops and updated cmsgpack backported. * [NEW] Transparent Huge Pages warnings and reporting backported. >> Cluster changes * [FIX] Fix PUBLISH cluster bus message count field. * [FIX] It is no longer possible to write outside node hash slots using Lua. * [FIX] Valgrind warnings (no actual bugs). * [FIX] Less strict in acceptiong myself->ip if it's not populated. * [NEW] Better testing of Lua scripts. >> Sentinel changes No changes to Sentinel. </ChangeLog>
47 lines
2 KiB
Text
47 lines
2 KiB
Text
--- src/Makefile.orig 2014-07-29 12:17:48.000000000 +0400
|
|
+++ src/Makefile 2014-09-10 02:30:38.000000000 +0400
|
|
@@ -15,7 +15,7 @@
|
|
release_hdr := $(shell sh -c './mkreleasehdr.sh')
|
|
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
|
|
OPTIMIZATION?=-O2
|
|
-DEPENDENCY_TARGETS=hiredis linenoise lua
|
|
+DEPENDENCY_TARGETS=hiredis linenoise
|
|
|
|
# Default settings
|
|
STD=-std=c99 -pedantic
|
|
@@ -49,7 +49,7 @@
|
|
# Override default settings if possible
|
|
-include .make-settings
|
|
|
|
-FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
|
|
+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
|
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
|
|
FINAL_LIBS=-lm
|
|
DEBUG=-g -ggdb
|
|
@@ -88,6 +88,9 @@
|
|
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
|
|
endif
|
|
|
|
+FINAL_CFLAGS+= -I${PREFIX}/include/luajit-2.0
|
|
+FINAL_LIBS+= -L${PREFIX}/lib -lluajit-5.1
|
|
+
|
|
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
|
|
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
|
|
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
|
|
@@ -108,6 +111,7 @@
|
|
REDIS_SERVER_NAME=redis-server
|
|
REDIS_SENTINEL_NAME=redis-sentinel
|
|
REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o
|
|
+REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
|
|
REDIS_CLI_NAME=redis-cli
|
|
REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
|
|
REDIS_BENCHMARK_NAME=redis-benchmark
|
|
@@ -162,7 +166,7 @@
|
|
|
|
# redis-server
|
|
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
|
|
- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS)
|
|
+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS)
|
|
|
|
# redis-sentinel
|
|
$(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)
|