2a58169b19
I am not touching the husky ports with a 10 foot pole. atp: stage, improve pkg-message crashmail: stage diablo: too wacky to stage, but convert WITH_* to OPTIONS, unmute commands that shouldn't be muted, use :MDOCS fidogate-ds: stage, OPTIONS, treat examples as EXAMPLES, not DOCS, handle /var/* in the plist properly golded+: stage, OPTIONS, protect examples behind %%PORTEXAMPLES%% nntpbtr: this was an unbelievably PITA stage, add missing prototypes, add missing return types, rename patch files to what they actually patch nntpcache: stage support, required lots of Makefile.in patching, call submakes correctly, handle config files properly nzbperl: stage, use OPTIONS, remove obsolete pkg-message papercut: stage, handle config file properly py-pynzb: stage, use OPTIONS helper to avoid bsd.port.options.mk inclusion s-news: stage slrnconf: stage slrnface: stage, install required files to datadir, not examplesdir, generate proper pkg-message sn: stage
27 lines
963 B
Text
27 lines
963 B
Text
--- Makefile.in.orig 2002-05-18 15:23:03.000000000 -0400
|
|
+++ Makefile.in 2014-03-29 13:01:10.000000000 -0400
|
|
@@ -113,7 +113,7 @@
|
|
$(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/$$p;\
|
|
done
|
|
for p in $(SCRIPTS); do\
|
|
- $(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/$$p;\
|
|
+ $(INSTALL_SCRIPT) $$p $(DESTDIR)$(sbindir)/$$p;\
|
|
done
|
|
$(INSTALL_DIRECTORY) $(DESTDIR)$(mandir)/man1
|
|
for p in $(MAN1PAGES); do\
|
|
@@ -123,12 +123,11 @@
|
|
for p in $(MAN8PAGES); do\
|
|
$(INSTALL_DATA) $$p $(DESTDIR)$(mandir)/man8/$$p;\
|
|
done
|
|
- $(INSTALL_VARDIR) $(spooldir)
|
|
- $(INSTALL_VARDIR) $(confdir)
|
|
- $(INSTALL_VARDIR) $(confdir)/suck
|
|
+ $(INSTALL_VARDIR) $(DESTDIR)$(spooldir)
|
|
+ $(INSTALL_VARDIR) $(DESTDIR)$(confdir)
|
|
for d in $(DATA); do\
|
|
if test ! -e $(DESTDIR)$(confdir)/$$d; then\
|
|
- $(INSTALL_VARDATA) data/$$d $(DESTDIR)$(confdir)/$$d;\
|
|
+ $(INSTALL_VARDATA) data/$$d $(DESTDIR)$(confdir)/$$d.sample;\
|
|
fi;\
|
|
done
|
|
if test ! -e $(DESTDIR)$(confdir)/put.news; then\
|