282836f1e2
Submitted from: knu
63 lines
2.5 KiB
Text
63 lines
2.5 KiB
Text
--- src/Makefile.in.orig Fri Jan 17 06:36:43 2003
|
|
+++ src/Makefile.in Thu Jan 23 01:41:33 2003
|
|
@@ -106,7 +106,7 @@
|
|
# some namespace hackery going on that maybe shouldn't be. Long term fix is to
|
|
# try and remove naming ocnflicts and fix Automake to allow particular includes
|
|
# to be attached only to particular object files. Short term fix is either or.
|
|
-INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/diff -I$(top_srcdir)/zlib $(includeopt)
|
|
+INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/diff $(includeopt)
|
|
|
|
bin_PROGRAMS = cvs
|
|
bin_SCRIPTS = cvsbug
|
|
@@ -147,6 +147,7 @@
|
|
no_diff.c \
|
|
parseinfo.c \
|
|
patch.c \
|
|
+ prepend_args.c \
|
|
rcs.c \
|
|
rcscmds.c \
|
|
recurse.c \
|
|
@@ -184,8 +185,7 @@
|
|
|
|
cvs_LDADD = \
|
|
../diff/libdiff.a \
|
|
- ../lib/libcvs.a \
|
|
- ../zlib/libz.a
|
|
+ ../lib/libcvs.a
|
|
|
|
|
|
# extra clean targets
|
|
@@ -221,6 +221,7 @@
|
|
main.$(OBJEXT) mkmodules.$(OBJEXT) modules.$(OBJEXT) \
|
|
myndbm.$(OBJEXT) no_diff.$(OBJEXT) parseinfo.$(OBJEXT) \
|
|
patch.$(OBJEXT) rcs.$(OBJEXT) rcscmds.$(OBJEXT) \
|
|
+ prepend_args.$(OBJEXT) \
|
|
recurse.$(OBJEXT) release.$(OBJEXT) remove.$(OBJEXT) \
|
|
repos.$(OBJEXT) root.$(OBJEXT) run.$(OBJEXT) scramble.$(OBJEXT) \
|
|
server.$(OBJEXT) status.$(OBJEXT) subr.$(OBJEXT) tag.$(OBJEXT) \
|
|
@@ -236,7 +237,7 @@
|
|
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
|
|
CPPFLAGS = @CPPFLAGS@
|
|
LDFLAGS = @LDFLAGS@
|
|
-LIBS = @LIBS@
|
|
+LIBS = @LIBS@ -lmd -lgnuregex -lz
|
|
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
am__depfiles_maybe = depfiles
|
|
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/add.Po ./$(DEPDIR)/admin.Po \
|
|
@@ -256,7 +257,7 @@
|
|
@AMDEP_TRUE@ ./$(DEPDIR)/main.Po ./$(DEPDIR)/mkmodules.Po \
|
|
@AMDEP_TRUE@ ./$(DEPDIR)/modules.Po ./$(DEPDIR)/myndbm.Po \
|
|
@AMDEP_TRUE@ ./$(DEPDIR)/no_diff.Po ./$(DEPDIR)/parseinfo.Po \
|
|
-@AMDEP_TRUE@ ./$(DEPDIR)/patch.Po ./$(DEPDIR)/rcs.Po \
|
|
+@AMDEP_TRUE@ ./$(DEPDIR)/patch.Po ./$(DEPDIR)/prepend_args.Po ./$(DEPDIR)/rcs.Po \
|
|
@AMDEP_TRUE@ ./$(DEPDIR)/rcscmds.Po ./$(DEPDIR)/recurse.Po \
|
|
@AMDEP_TRUE@ ./$(DEPDIR)/release.Po ./$(DEPDIR)/remove.Po \
|
|
@AMDEP_TRUE@ ./$(DEPDIR)/repos.Po ./$(DEPDIR)/root.Po \
|
|
@@ -375,6 +376,7 @@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/no_diff.Po@am__quote@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/parseinfo.Po@am__quote@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/patch.Po@am__quote@
|
|
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/prepend_args.Po@am__quote@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rcs.Po@am__quote@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/rcscmds.Po@am__quote@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/recurse.Po@am__quote@
|