c90874ad51
- New program ssh-keysign - New manpages for ssh_config and sshd_config - Merge Pathes to new files - Fix GCC problem with unsupported __func__ in older Releases
45 lines
1.1 KiB
Text
45 lines
1.1 KiB
Text
--- sshd/Makefile.orig Fri Jun 21 23:06:22 2002
|
|
+++ sshd/Makefile Fri Jun 21 23:06:56 2002
|
|
@@ -5,8 +5,9 @@
|
|
PROG= sshd
|
|
BINOWN= root
|
|
BINMODE=555
|
|
-BINDIR= /usr/sbin
|
|
-MAN= sshd.8 sshd_config.5
|
|
+BINDIR= /sbin
|
|
+MAN8= sshd.8
|
|
+MAN5= sshd_config.5
|
|
#CFLAGS+=-DHAVE_LOGIN_CAP -DBSD_AUTH
|
|
CFLAGS+=-DHAVE_LOGIN_CAP
|
|
|
|
@@ -19,9 +20,10 @@
|
|
auth2-hostbased.c auth2-kbdint.c
|
|
|
|
.include <bsd.own.mk> # for KERBEROS and AFS
|
|
+.include "../Makefile.inc"
|
|
|
|
.if (${KERBEROS5:L} == "yes")
|
|
-CFLAGS+=-DKRB5 -I${DESTDIR}/usr/include/kerberosV
|
|
+CFLAGS+=-DKRB5 -I/usr/include/kerberosV
|
|
SRCS+= auth-krb5.c
|
|
LDADD+= -lkrb5 -lkafs -lasn1 -lcom_err
|
|
DPADD+= ${LIBKRB5} ${LIBKAFS} ${LIBASN1} ${LIBCOM_ERR}
|
|
@@ -33,15 +35,15 @@
|
|
LDADD+= -lkafs
|
|
DPADD+= ${LIBKAFS}
|
|
.endif # AFS
|
|
-CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV
|
|
+CFLAGS+= -DKRB4 -I/usr/include/kerberosIV
|
|
SRCS+= auth-krb4.c
|
|
-LDADD+= -lkrb
|
|
+LDADD+= -lkrb -lcom_err
|
|
DPADD+= ${LIBKRB}
|
|
.endif # KERBEROS
|
|
|
|
.include <bsd.prog.mk>
|
|
|
|
-LDADD+= -lcrypto -lutil -lz -ldes
|
|
+LDADD+= ${CRYPTOLIBS} -lcrypt -lutil -lz
|
|
DPADD+= ${LIBCRYPTO} ${LIBUTIL} ${LIBZ} ${LIBDES}
|
|
|
|
.if (${TCP_WRAPPERS:L} == "yes")
|