19 lines
1.1 KiB
Text
19 lines
1.1 KiB
Text
--- src/findlib/Makefile.orig 2009-09-10 22:05:21.000000000 +0200
|
|
+++ src/findlib/Makefile 2009-09-11 09:24:04.000000000 +0200
|
|
@@ -17,6 +17,7 @@ OCAMLDEP = ocamldep
|
|
OCAMLLEX = ocamllex
|
|
CAMLP4O = camlp4 pa_o.cmo pa_op.cmo pr_o.cmo --
|
|
#CAMLP4O = camlp4 pa_o.cmo pa_op.cmo pr_dump.cmo --
|
|
+OCAML_LIBBIN=${PREFIX}/lib/ocaml
|
|
|
|
|
|
OBJECTS = findlib_config.cmo fl_split.cmo fl_metatoken.cmo fl_meta.cmo \
|
|
@@ -80,7 +81,7 @@ clean:
|
|
install: all
|
|
mkdir -p "$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
|
mkdir -p "$(prefix)$(OCAMLFIND_BIN)"
|
|
- test $(INSTALL_TOPFIND) -eq 0 || cp topfind "$(prefix)$(OCAML_CORE_STDLIB)"
|
|
+ test $(INSTALL_TOPFIND) -eq 0 || cp topfind "$(prefix)$(OCAML_LIBBIN)"
|
|
files=`$(TOP)/tools/collect_files $(TOP)/Makefile.config findlib.cmi findlib.mli findlib.cma topfind.cmi topfind.mli fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi fl_metatoken.cmi findlib_top.cma findlib.cmxa findlib.a META` && \
|
|
cp $$files "$(prefix)$(OCAML_SITELIB)/$(NAME)"
|
|
f="ocamlfind$(EXEC_SUFFIX)"; { test -f ocamlfind_opt$(EXEC_SUFFIX) && f="ocamlfind_opt$(EXEC_SUFFIX)"; }; \
|