freebsd-ports/editors/emacs20/files/patch-cc
FUJISHIMA Satsuki c1c1b2fca0 Tidy up Makefile: double negative condition check si not good.
PR:		23504
Submitted by:	Giorgos Keramidas <keramida@westgate.gr>

remove xpg4 hack and process it through autoconf.
2001-09-22 21:56:21 +00:00

43 lines
1.4 KiB
Text

--- configure.in.orig Tue Jun 6 00:42:49 2000
+++ configure.in Sun Sep 23 06:53:04 2001
@@ -147,6 +147,15 @@
machine='' opsys='' unported=no
case "${canonical}" in
+ ## FreeBSD ports
+ *-*-freebsd* )
+ opsys=freebsd
+ case "${canonical}" in
+ alpha*-*-freebsd*) machine=alpha ;;
+ i[3456]86-*-freebsd*) machine=intel386 ;;
+ esac
+ ;;
+
## NetBSD ports
*-*-netbsd* )
opsys=netbsd
@@ -958,7 +967,6 @@
;;
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-386bsd* ) opsys=386bsd ;;
- *-freebsd* ) opsys=freebsd ;;
*-nextstep* ) opsys=nextstep ;;
## Otherwise, we'll fall through to the generic opsys code at the bottom.
esac
@@ -1639,7 +1647,7 @@
rename closedir mkdir rmdir sysinfo \
random lrand48 bcopy bcmp logb frexp fmod rint cbrt ftime res_init setsid \
strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
-utimes setrlimit setpgid getcwd shutdown strftime)
+utimes setrlimit setpgid getcwd shutdown strftime getaddrinfo)
# UNIX98 PTYs.
AC_CHECK_FUNCS(grantpt)
@@ -1656,6 +1664,7 @@
# Solaris requires -lintl if you want strerror (which calls dgettext)
# to return localized messages.
AC_CHECK_LIB(intl, dgettext)
+AC_CHECK_LIB(xpg4, _xpg4_setrunelocale)
AC_MSG_CHECKING(whether localtime caches TZ)
AC_CACHE_VAL(emacs_cv_localtime_cache,