freebsd-ports/x11-toolkits/copperspice/files/patch-src_script_CMakeLists.txt
Adriaan de Groot 8de46b4745 x11-toolkits/copperspice: resurrect CopperSpice
CopperSpice is a toolkit, forked from Qt and updated to use
modern C++ and CMake in the Qt 5.something LGPL days. It was
removed from the tree for being unfetchable in 2017, now
restored. I didn't bother to look at the old ports files, so
this is entirely new work.

CS builds cleanly, except I patched in -pthread as a linker
option; I think this ought to be part of the Threads package
found by CMake, but it isn't (on FreeBSD at least). Some linkage
options need to be PUBLIC to be carried through to consuming
applications (this is a FreeBSD thing).

While here, introduce the misc/copperspice-examples which
is a demo application *kitchensink* that exercises the libraries.

CopperSpice shares notional-filenames with Qt (e.g. binaries
called "lupdate" for UI design) but the Qt ports are versioned
("lupdate-qt5"). CopperSpice gets "-cs" as a suffix.

There's a bunch of patching to make things "behave" like a
regularly packaged set of libraries and applications that
consume those libraries. In particular using $(LOCALBASE)/share/
rather than putting everything in the same target directory.
2022-02-20 16:45:27 +01:00

22 lines
727 B
Text

--- src/script/CMakeLists.txt.orig 2022-01-14 18:52:21 UTC
+++ src/script/CMakeLists.txt
@@ -569,7 +569,7 @@ target_sources(CsScript
target_include_directories(CsScript
PUBLIC
- $<INSTALL_INTERFACE:include/QtScript>
+ ${CMAKE_INSTALL_INCLUDEDIR}/QtScript
)
target_link_libraries(CsScript
@@ -596,8 +596,8 @@ install(
TARGETS CsScript
EXPORT CopperSpiceLibraryTargets ${INSTALL_TARGETS_DEFAULT_ARGS}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
)
install(