8de46b4745
CopperSpice is a toolkit, forked from Qt and updated to use modern C++ and CMake in the Qt 5.something LGPL days. It was removed from the tree for being unfetchable in 2017, now restored. I didn't bother to look at the old ports files, so this is entirely new work. CS builds cleanly, except I patched in -pthread as a linker option; I think this ought to be part of the Threads package found by CMake, but it isn't (on FreeBSD at least). Some linkage options need to be PUBLIC to be carried through to consuming applications (this is a FreeBSD thing). While here, introduce the misc/copperspice-examples which is a demo application *kitchensink* that exercises the libraries. CopperSpice shares notional-filenames with Qt (e.g. binaries called "lupdate" for UI design) but the Qt ports are versioned ("lupdate-qt5"). CopperSpice gets "-cs" as a suffix. There's a bunch of patching to make things "behave" like a regularly packaged set of libraries and applications that consume those libraries. In particular using $(LOCALBASE)/share/ rather than putting everything in the same target directory.
22 lines
699 B
Text
22 lines
699 B
Text
--- src/xml/CMakeLists.txt.orig 2022-01-14 18:52:21 UTC
|
|
+++ src/xml/CMakeLists.txt
|
|
@@ -44,7 +44,7 @@ target_sources(CsXml
|
|
|
|
target_include_directories(CsXml
|
|
PUBLIC
|
|
- $<INSTALL_INTERFACE:include/QtXml>
|
|
+ ${CMAKE_INSTALL_INCLUDEDIR}/QtXml
|
|
)
|
|
|
|
target_link_libraries(CsXml
|
|
@@ -71,8 +71,8 @@ install(
|
|
TARGETS CsXml
|
|
EXPORT CopperSpiceLibraryTargets ${INSTALL_TARGETS_DEFAULT_ARGS}
|
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
|
|
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
|
|
)
|
|
|
|
install(
|